summaryrefslogtreecommitdiffstats
path: root/python/simplejson/simplejson.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/simplejson/simplejson.SlackBuild')
-rw-r--r--python/simplejson/simplejson.SlackBuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/python/simplejson/simplejson.SlackBuild b/python/simplejson/simplejson.SlackBuild
index 588fabb55b..58b75434da 100644
--- a/python/simplejson/simplejson.SlackBuild
+++ b/python/simplejson/simplejson.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for simplejson
-# Copyright 2009-2014 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2009-2015 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=simplejson
-VERSION=${VERSION:-3.5.3}
+VERSION=${VERSION:-3.8.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -58,11 +58,13 @@ find -L . \
# Make documents if Sphinx and Pygments are installed.
if $(python -c 'import sphinx.pygments_styles' 2>/dev/null); then
python scripts/make_docs.py
+ rm -f docs/.buildinfo
+ rm -f docs/.nojekyll
fi
python setup.py install --root=$PKG
-if $(python3 -c 'import os' 2>/dev/null); then
+if [ "${PYTHON3:-no}" == "yes" ]; then
python3 setup.py install --root=$PKG
fi