summaryrefslogtreecommitdiffstats
path: root/python/pyusb
diff options
context:
space:
mode:
Diffstat (limited to 'python/pyusb')
-rw-r--r--python/pyusb/README4
-rw-r--r--python/pyusb/pyusb.SlackBuild28
-rw-r--r--python/pyusb/pyusb.info8
3 files changed, 25 insertions, 15 deletions
diff --git a/python/pyusb/README b/python/pyusb/README
index 9c8a61e6b1..4c04a75044 100644
--- a/python/pyusb/README
+++ b/python/pyusb/README
@@ -1,2 +1,4 @@
-PyUSB is a native Python module which provides easy USB access to Python.
+PyUSB is a native Python module which provides easy USB access to
+Python.
+
The module contains classes and methods to support most USB operations.
diff --git a/python/pyusb/pyusb.SlackBuild b/python/pyusb/pyusb.SlackBuild
index 69cb9e5d1e..2b51a49d86 100644
--- a/python/pyusb/pyusb.SlackBuild
+++ b/python/pyusb/pyusb.SlackBuild
@@ -1,4 +1,4 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for PyUSB
@@ -22,10 +22,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=pyusb
-VERSION=${VERSION:-1.1.1}
+VERSION=${VERSION:-1.2.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$(uname -m)" in
@@ -35,9 +38,16 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM-$VERSION
+PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
DOCS="ACKNOWLEDGEMENTS LICENSE README.rst docs/faq.rst docs/tutorial.rst"
@@ -55,11 +65,9 @@ chmod -R u+w,go-w,a+rX-st .
# Can't build the git snapshot. Upstream publishes a modified copy
# (with version metadata that setup.py needs), see setuptools-scm.
-python2 ./setup.py install --root=$PKG
-if python3 -c 'import sys' 2>/dev/null; then
- rm -rf build
- python3 ./setup.py install --root=$PKG
-fi
+python2 setup.py install --root=$PKG
+rm -rf build
+python3 setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
@@ -69,4 +77,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/pyusb/pyusb.info b/python/pyusb/pyusb.info
index 2531a3f5b9..6312a8df53 100644
--- a/python/pyusb/pyusb.info
+++ b/python/pyusb/pyusb.info
@@ -1,10 +1,10 @@
PRGNAM="pyusb"
-VERSION="1.1.1"
+VERSION="1.2.1"
HOMEPAGE="https://pyusb.github.io/pyusb/"
-DOWNLOAD="https://github.com/pyusb/pyusb/releases/download/v1.1.1/pyusb-1.1.1.tar.gz"
-MD5SUM="a9db479f1fb914e91d3106e67a13ae09"
+DOWNLOAD="https://github.com/pyusb/pyusb/releases/download/v1.2.1/pyusb-1.2.1.tar.gz"
+MD5SUM="880008dff32dac8f58076b4e534492d9"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="python2-setuptools-scm"
MAINTAINER="Kyle Guinn"
EMAIL="elyk03@gmail.com"