summaryrefslogtreecommitdiffstats
path: root/python/python3/patches/python3.x86_64.diff
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3/patches/python3.x86_64.diff')
-rw-r--r--python/python3/patches/python3.x86_64.diff54
1 files changed, 27 insertions, 27 deletions
diff --git a/python/python3/patches/python3.x86_64.diff b/python/python3/patches/python3.x86_64.diff
index 182fc62932..cf2c46aa5f 100644
--- a/python/python3/patches/python3.x86_64.diff
+++ b/python/python3/patches/python3.x86_64.diff
@@ -1,6 +1,6 @@
-diff -uar Python-3.6.1.orig/Lib/distutils/command/install.py Python-3.6.1/Lib/distutils/command/install.py
---- Python-3.6.1.orig/Lib/distutils/command/install.py 2017-03-21 08:32:38.000000000 +0200
-+++ Python-3.6.1/Lib/distutils/command/install.py 2017-03-22 21:42:23.915962369 +0200
+diff -uar Python-3.6.2.orig/Lib/distutils/command/install.py Python-3.6.2/Lib/distutils/command/install.py
+--- Python-3.6.2.orig/Lib/distutils/command/install.py 2017-07-08 06:33:27.000000000 +0300
++++ Python-3.6.2/Lib/distutils/command/install.py 2017-08-20 15:10:41.653336676 +0300
@@ -29,15 +29,15 @@
INSTALL_SCHEMES = {
@@ -21,10 +21,10 @@ diff -uar Python-3.6.1.orig/Lib/distutils/command/install.py Python-3.6.1/Lib/di
'headers': '$base/include/python/$dist_name',
'scripts': '$base/bin',
'data' : '$base',
-diff -uar Python-3.6.1.orig/Lib/distutils/sysconfig.py Python-3.6.1/Lib/distutils/sysconfig.py
---- Python-3.6.1.orig/Lib/distutils/sysconfig.py 2017-03-21 08:32:38.000000000 +0200
-+++ Python-3.6.1/Lib/distutils/sysconfig.py 2017-03-22 21:42:23.915962369 +0200
-@@ -133,7 +133,7 @@
+diff -uar Python-3.6.2.orig/Lib/distutils/sysconfig.py Python-3.6.2/Lib/distutils/sysconfig.py
+--- Python-3.6.2.orig/Lib/distutils/sysconfig.py 2017-07-08 06:33:27.000000000 +0300
++++ Python-3.6.2/Lib/distutils/sysconfig.py 2017-08-20 15:10:41.654336706 +0300
+@@ -130,7 +130,7 @@
if os.name == "posix":
libpython = os.path.join(prefix,
@@ -33,9 +33,9 @@ diff -uar Python-3.6.1.orig/Lib/distutils/sysconfig.py Python-3.6.1/Lib/distutil
if standard_lib:
return libpython
else:
-diff -uar Python-3.6.1.orig/Lib/site.py Python-3.6.1/Lib/site.py
---- Python-3.6.1.orig/Lib/site.py 2017-03-21 08:32:38.000000000 +0200
-+++ Python-3.6.1/Lib/site.py 2017-03-22 21:42:23.915962369 +0200
+diff -uar Python-3.6.2.orig/Lib/site.py Python-3.6.2/Lib/site.py
+--- Python-3.6.2.orig/Lib/site.py 2017-07-08 06:33:27.000000000 +0300
++++ Python-3.6.2/Lib/site.py 2017-08-20 15:10:41.654336706 +0300
@@ -304,7 +304,7 @@
seen.add(prefix)
@@ -45,9 +45,9 @@ diff -uar Python-3.6.1.orig/Lib/site.py Python-3.6.1/Lib/site.py
"python%d.%d" % sys.version_info[:2],
"site-packages"))
else:
-diff -uar Python-3.6.1.orig/Lib/sysconfig.py Python-3.6.1/Lib/sysconfig.py
---- Python-3.6.1.orig/Lib/sysconfig.py 2017-03-21 08:32:38.000000000 +0200
-+++ Python-3.6.1/Lib/sysconfig.py 2017-03-22 21:42:23.916962405 +0200
+diff -uar Python-3.6.2.orig/Lib/sysconfig.py Python-3.6.2/Lib/sysconfig.py
+--- Python-3.6.2.orig/Lib/sysconfig.py 2017-07-08 06:33:27.000000000 +0300
++++ Python-3.6.2/Lib/sysconfig.py 2017-08-20 15:10:41.654336706 +0300
@@ -20,10 +20,10 @@
_INSTALL_SCHEMES = {
@@ -93,10 +93,10 @@ diff -uar Python-3.6.1.orig/Lib/sysconfig.py Python-3.6.1/Lib/sysconfig.py
'include': '{userbase}/include/python{py_version_short}',
'scripts': '{userbase}/bin',
'data': '{userbase}',
-diff -uar Python-3.6.1.orig/Makefile.pre.in Python-3.6.1/Makefile.pre.in
---- Python-3.6.1.orig/Makefile.pre.in 2017-03-21 08:32:38.000000000 +0200
-+++ Python-3.6.1/Makefile.pre.in 2017-03-22 21:42:23.916962405 +0200
-@@ -131,7 +131,7 @@
+diff -uar Python-3.6.2.orig/Makefile.pre.in Python-3.6.2/Makefile.pre.in
+--- Python-3.6.2.orig/Makefile.pre.in 2017-07-08 06:33:27.000000000 +0300
++++ Python-3.6.2/Makefile.pre.in 2017-08-20 15:10:41.655336736 +0300
+@@ -133,7 +133,7 @@
MANDIR= @mandir@
INCLUDEDIR= @includedir@
CONFINCLUDEDIR= $(exec_prefix)/include
@@ -105,9 +105,9 @@ diff -uar Python-3.6.1.orig/Makefile.pre.in Python-3.6.1/Makefile.pre.in
ABIFLAGS= @ABIFLAGS@
# Detailed destination directories
-diff -uar Python-3.6.1.orig/Modules/getpath.c Python-3.6.1/Modules/getpath.c
---- Python-3.6.1.orig/Modules/getpath.c 2017-03-21 08:32:38.000000000 +0200
-+++ Python-3.6.1/Modules/getpath.c 2017-03-22 21:42:23.917962441 +0200
+diff -uar Python-3.6.2.orig/Modules/getpath.c Python-3.6.2/Modules/getpath.c
+--- Python-3.6.2.orig/Modules/getpath.c 2017-07-08 06:33:27.000000000 +0300
++++ Python-3.6.2/Modules/getpath.c 2017-08-20 15:10:41.655336736 +0300
@@ -494,7 +494,7 @@
_pythonpath = Py_DecodeLocale(PYTHONPATH, NULL);
_prefix = Py_DecodeLocale(PREFIX, NULL);
@@ -135,10 +135,10 @@ diff -uar Python-3.6.1.orig/Modules/getpath.c Python-3.6.1/Modules/getpath.c
}
/* If we found EXEC_PREFIX do *not* reduce it! (Yet.) */
-diff -uar Python-3.6.1.orig/configure Python-3.6.1/configure
---- Python-3.6.1.orig/configure 2017-03-21 08:32:38.000000000 +0200
-+++ Python-3.6.1/configure 2017-03-22 21:42:23.920962550 +0200
-@@ -14963,9 +14963,9 @@
+diff -uar Python-3.6.2.orig/configure Python-3.6.2/configure
+--- Python-3.6.2.orig/configure 2017-07-08 06:33:27.000000000 +0300
++++ Python-3.6.2/configure 2017-08-20 15:10:41.658336826 +0300
+@@ -15006,9 +15006,9 @@
if test x$PLATFORM_TRIPLET = x; then
@@ -150,9 +150,9 @@ diff -uar Python-3.6.1.orig/configure Python-3.6.1/configure
fi
-diff -uar Python-3.6.1.orig/setup.py Python-3.6.1/setup.py
---- Python-3.6.1.orig/setup.py 2017-03-21 08:32:38.000000000 +0200
-+++ Python-3.6.1/setup.py 2017-03-22 21:47:59.638077062 +0200
+diff -uar Python-3.6.2.orig/setup.py Python-3.6.2/setup.py
+--- Python-3.6.2.orig/setup.py 2017-07-08 06:33:27.000000000 +0300
++++ Python-3.6.2/setup.py 2017-08-20 15:10:41.659336856 +0300
@@ -491,7 +491,7 @@
# directories (i.e. '.' and 'Include') must be first. See issue
# 10520.