summaryrefslogtreecommitdiffstats
path: root/python/python3-seaborn
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-seaborn')
-rw-r--r--python/python3-seaborn/README6
-rw-r--r--python/python3-seaborn/python3-seaborn.SlackBuild37
-rw-r--r--python/python3-seaborn/python3-seaborn.info10
3 files changed, 26 insertions, 27 deletions
diff --git a/python/python3-seaborn/README b/python/python3-seaborn/README
index c11a97b528..2364d99803 100644
--- a/python/python3-seaborn/README
+++ b/python/python3-seaborn/README
@@ -1,6 +1,6 @@
Seaborn is a Python data visualization library based on matplotlib.
-It provides a high-level interface for drawing attractive and
+It provides a high-level interface for drawing attractive and
informative statistical graphics.
-python3-statsmodels (optional) provides advanced statistical
-plot functions.
+python3-scipy and python3-statsmodels (both optional) provide advanced
+statistical plot functions.
diff --git a/python/python3-seaborn/python3-seaborn.SlackBuild b/python/python3-seaborn/python3-seaborn.SlackBuild
index b25f8e34fd..bac7684b82 100644
--- a/python/python3-seaborn/python3-seaborn.SlackBuild
+++ b/python/python3-seaborn/python3-seaborn.SlackBuild
@@ -1,8 +1,8 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for python3-seaborn
-# Copyright 2020 Isaac Yu <isaacyu1@isaacyu1.com>
+# Copyright 2020-2024 Isaac Yu <isaacyu@protonmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,11 +22,15 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=python3-seaborn
-VERSION=${VERSION:-0.10.0}
-SRCNAM=seaborn
+VERSION=${VERSION:-0.13.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+SRCNAM=seaborn
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -36,27 +40,21 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- LIBDIRSUFFIX="64"
-else
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $SRCNAM-VERSION
+rm -rf $SRCNAM-$VERSION
tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
cd $SRCNAM-$VERSION
chown -R root:root .
@@ -66,17 +64,18 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE README.md requirements.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE.md README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-seaborn/python3-seaborn.info b/python/python3-seaborn/python3-seaborn.info
index c8b161a35b..979abf8768 100644
--- a/python/python3-seaborn/python3-seaborn.info
+++ b/python/python3-seaborn/python3-seaborn.info
@@ -1,10 +1,10 @@
PRGNAM="python3-seaborn"
-VERSION="0.10.0"
+VERSION="0.13.2"
HOMEPAGE="https://seaborn.pydata.org/"
-DOWNLOAD="https://github.com/mwaskom/seaborn/archive/v0.10.0/seaborn-0.10.0.tar.gz"
-MD5SUM="605c25770cd0a4a4146c1788966725e7"
+DOWNLOAD="https://github.com/mwaskom/seaborn/archive/v0.13.2/seaborn-0.13.2.tar.gz"
+MD5SUM="5e18d5141b2c7db84948e64a8076ab09"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python3-matplotlib python3-pandas scipy3"
+REQUIRES="python3-matplotlib python3-pandas"
MAINTAINER="Isaac Yu"
-EMAIL="isaacyu1@isaacyu1.com"
+EMAIL="isaacyu@protonmail.com"