summaryrefslogtreecommitdiffstats
path: root/python/python3-jsonschema/python3-jsonschema.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-jsonschema/python3-jsonschema.SlackBuild')
-rw-r--r--python/python3-jsonschema/python3-jsonschema.SlackBuild43
1 files changed, 20 insertions, 23 deletions
diff --git a/python/python3-jsonschema/python3-jsonschema.SlackBuild b/python/python3-jsonschema/python3-jsonschema.SlackBuild
index e95d835e4d..4e78831f1e 100644
--- a/python/python3-jsonschema/python3-jsonschema.SlackBuild
+++ b/python/python3-jsonschema/python3-jsonschema.SlackBuild
@@ -1,7 +1,8 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for python3-jsonschema
+# Copyright 2022-2024 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# Copyright 2019 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# Based on jsonschema by Dimitris Zlatanidis
# All rights reserved.
@@ -23,11 +24,16 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-SRCNAM=jsonschema
-PRGNAM=python3-$SRCNAM
-VERSION=${VERSION:-3.2.0}
+# 20221128 46and2: Updated version, new maintainer.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-jsonschema
+SRCNAM=${PRGNAM#python3-*}
+VERSION=${VERSION:-4.17.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -37,25 +43,15 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -67,11 +63,12 @@ cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-python3 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -86,4 +83,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE