summaryrefslogtreecommitdiffstats
path: root/python/python3-isort/python3-isort.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-isort/python3-isort.SlackBuild')
-rw-r--r--python/python3-isort/python3-isort.SlackBuild27
1 files changed, 18 insertions, 9 deletions
diff --git a/python/python3-isort/python3-isort.SlackBuild b/python/python3-isort/python3-isort.SlackBuild
index 04e2475e75..d929624828 100644
--- a/python/python3-isort/python3-isort.SlackBuild
+++ b/python/python3-isort/python3-isort.SlackBuild
@@ -1,7 +1,8 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for python3-isort
+# Copyright 2022 Dimitris Zlatanidis Orestiada, Greece
# Copyright 2018 Markus Rinne Finland
# All rights reserved.
#
@@ -22,11 +23,14 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=python3-isort
SRCNAM=isort
-VERSION=${VERSION:-5.7.0}
+VERSION=${VERSION:-5.11.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -36,7 +40,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -72,20 +83,18 @@ find -L . \
python3 setup.py install --root=$PKG
-# Remove isort binary, because it is contained in Python 2 version of isort package.
-rm $PKG/usr/bin/isort
+# Rename isort binary, because it is contained in Python 2 version of isort package.
+mv $PKG/usr/bin/isort $PKG/usr/bin/isort3
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- PKG-INFO README.md \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a PKG-INFO README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE