summaryrefslogtreecommitdiffstats
path: root/python/python3-gnutls
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-gnutls')
-rw-r--r--python/python3-gnutls/README15
-rw-r--r--python/python3-gnutls/python3-gnutls.SlackBuild100
-rw-r--r--python/python3-gnutls/python3-gnutls.info10
-rw-r--r--python/python3-gnutls/slack-desc19
4 files changed, 144 insertions, 0 deletions
diff --git a/python/python3-gnutls/README b/python/python3-gnutls/README
new file mode 100644
index 0000000000..821c3f1ee2
--- /dev/null
+++ b/python/python3-gnutls/README
@@ -0,0 +1,15 @@
+Python wrapper for the GnuTLS library
+
+This package provides a high level object oriented wrapper around
+libgnutls, as well as low level bindings to the GnuTLS types and
+functions via ctypes. The high level wrapper hides the details of
+accessing the GnuTLS library via ctypes behind a set of classes that
+encapsulate GnuTLS sessions, certificates and credentials and expose
+them to python applications using a simple API.
+
+The package also includes a Twisted interface that has seamless
+intergration with Twisted, providing connectTLS and listenTLS methods
+on the Twisted reactor once imported (the methods are automatically
+attached to the reactor by simply importing the GnuTLS Twisted
+interface module).
+
diff --git a/python/python3-gnutls/python3-gnutls.SlackBuild b/python/python3-gnutls/python3-gnutls.SlackBuild
new file mode 100644
index 0000000000..724429cf55
--- /dev/null
+++ b/python/python3-gnutls/python3-gnutls.SlackBuild
@@ -0,0 +1,100 @@
+#!/bin/bash
+
+# Slackware build script for python3-gnutls
+
+# Copyright 2023, Lockywolf
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-gnutls
+VERSION=${VERSION:-3.1.10}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-release-$VERSION
+tar xvf $CWD/$PRGNAM-release-$VERSION.tar.gz
+cd $PRGNAM-release-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ ChangeLog LICENSE README \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-gnutls/python3-gnutls.info b/python/python3-gnutls/python3-gnutls.info
new file mode 100644
index 0000000000..af1d5ef5e0
--- /dev/null
+++ b/python/python3-gnutls/python3-gnutls.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-gnutls"
+VERSION="3.1.10"
+HOMEPAGE="https://github.com/AGProjects/python3-gnutls"
+DOWNLOAD="https://github.com/AGProjects/python3-gnutls/archive/release-3.1.10/python3-gnutls-release-3.1.10.tar.gz"
+MD5SUM="bf26a9514fe0f469f5cb2faea4421476"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Lockywolf"
+EMAIL="for_sbo.python3-gnutls_2023-09-22@lockywolf.net"
diff --git a/python/python3-gnutls/slack-desc b/python/python3-gnutls/slack-desc
new file mode 100644
index 0000000000..b591ede3ae
--- /dev/null
+++ b/python/python3-gnutls/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-gnutls: python3-gnutls (Python wrapper for the GnuTLS library)
+python3-gnutls:
+python3-gnutls: This package provides a high level object oriented wrapper around
+python3-gnutls: libgnutls, as well as low level bindings to the GnuTLS types and
+python3-gnutls: functions via ctypes. The high level wrapper hides the details of
+python3-gnutls: accessing the GnuTLS library via ctypes behind a set of classes that
+python3-gnutls: encapsulate GnuTLS sessions, certificates and credentials and expose
+python3-gnutls: them to python applications using a simple API.
+python3-gnutls:
+python3-gnutls:
+python3-gnutls: