summaryrefslogtreecommitdiffstats
path: root/python/python3-glances/python3-glances.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-glances/python3-glances.SlackBuild')
-rw-r--r--python/python3-glances/python3-glances.SlackBuild25
1 files changed, 7 insertions, 18 deletions
diff --git a/python/python3-glances/python3-glances.SlackBuild b/python/python3-glances/python3-glances.SlackBuild
index 0a966b3d46..d211b2bebc 100644
--- a/python/python3-glances/python3-glances.SlackBuild
+++ b/python/python3-glances/python3-glances.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-glances
-# Copyright 2022-23 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# Copyright 2022-2024 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,11 +22,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20240323 46and2: Updated version, change to pep517 build.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-glances
SRCNAM=${PRGNAM#python3-*}
-VERSION=${VERSION:-3.4.0.3}
+VERSION=${VERSION:-3.4.0.5}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -48,20 +50,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -80,12 +68,13 @@ find -L . \
#change location to install man pages
sed -i 's|share/man|man|g' setup.py
-python3 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-find $PKG/usr/man -type f -exec gzip -9 {} \;
+find $PKG/usr/man -type f -exec gzip -9 {} \+
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
#cleanup usr/share