summaryrefslogtreecommitdiffstats
path: root/python/python3-deluge-client
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-deluge-client')
-rw-r--r--python/python3-deluge-client/README10
-rw-r--r--python/python3-deluge-client/python3-deluge-client.SlackBuild80
-rw-r--r--python/python3-deluge-client/python3-deluge-client.info10
-rw-r--r--python/python3-deluge-client/slack-desc19
4 files changed, 119 insertions, 0 deletions
diff --git a/python/python3-deluge-client/README b/python/python3-deluge-client/README
new file mode 100644
index 0000000000..9095c3e455
--- /dev/null
+++ b/python/python3-deluge-client/README
@@ -0,0 +1,10 @@
+python3-deluge-client (Very lightweight pure-python Deluge RPC Client)
+
+A lightweight pure-python rpc client for deluge. Note, does not
+support events and any additional replies from deluge will mess up
+the datastream.
+
+NOTE: This is a required dependency for another program, but it is not
+required to be functional. Rather than adding all the dependencies of
+deluge itself, deluge will not be added to REQUIRES line. If you need
+deluge support with this module, you will need to install deluge itself.
diff --git a/python/python3-deluge-client/python3-deluge-client.SlackBuild b/python/python3-deluge-client/python3-deluge-client.SlackBuild
new file mode 100644
index 0000000000..40dac0a760
--- /dev/null
+++ b/python/python3-deluge-client/python3-deluge-client.SlackBuild
@@ -0,0 +1,80 @@
+#!/bin/bash
+
+# Slackware build script for python3-deluge-client
+
+# Copyright 2023-2024 Jeremy Hansen jebrhansen+SBo@gmail.com
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-deluge-client
+VERSION=${VERSION:-1.10.2}
+SRCNAM=${SRCNAM:-deluge-client}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ LICENSE README.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-deluge-client/python3-deluge-client.info b/python/python3-deluge-client/python3-deluge-client.info
new file mode 100644
index 0000000000..fe7b40b1dd
--- /dev/null
+++ b/python/python3-deluge-client/python3-deluge-client.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-deluge-client"
+VERSION="1.10.2"
+HOMEPAGE="https://github.com/JohnDoee/deluge-client"
+DOWNLOAD="https://github.com/JohnDoee/deluge-client/archive/refs/tags/1.10.2/deluge-client-1.10.2.tar.gz"
+MD5SUM="12303dc80ecbd8427f8d0f6469710b0e"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Jeremy Hansen"
+EMAIL="jebrhansen+SBo@gmail.com"
diff --git a/python/python3-deluge-client/slack-desc b/python/python3-deluge-client/slack-desc
new file mode 100644
index 0000000000..e668f77fed
--- /dev/null
+++ b/python/python3-deluge-client/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-deluge-client: python3-deluge-client (Very lightweight pure-python Deluge RPC Client)
+python3-deluge-client:
+python3-deluge-client: A lightweight pure-python rpc client for deluge. Note, does not
+python3-deluge-client: support events and any additional replies from deluge will mess up
+python3-deluge-client: the datastream.
+python3-deluge-client:
+python3-deluge-client: HOMEPAGE: https://github.com/JohnDoee/deluge-client
+python3-deluge-client:
+python3-deluge-client:
+python3-deluge-client:
+python3-deluge-client: