summaryrefslogtreecommitdiffstats
path: root/python/python3-billiard
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-billiard')
-rw-r--r--python/python3-billiard/README15
-rw-r--r--python/python3-billiard/python3-billiard.SlackBuild77
-rw-r--r--python/python3-billiard/python3-billiard.info10
-rw-r--r--python/python3-billiard/slack-desc19
4 files changed, 121 insertions, 0 deletions
diff --git a/python/python3-billiard/README b/python/python3-billiard/README
new file mode 100644
index 0000000000..7ea6254fd5
--- /dev/null
+++ b/python/python3-billiard/README
@@ -0,0 +1,15 @@
+billiard is a fork of the Python 2.7 multiprocessing package.
+The multiprocessing package itself is a renamed and updated version of
+R Oudkerk's pyprocessing package.
+This standalone variant draws its fixes/improvements from python-trunk
+and provides additional bug fixes and improvements.
+
+* This package would not be possible if not for the contributions of not
+ only the current maintainers but all of the contributors to the
+ original pyprocessing package listed here.
+* Also, it is a fork of the multiprocessing backport package by
+ Christian Heims.
+* It includes the no-execv patch contributed by R. Oudkerk.
+* And the Pool improvements previously located in Celery.
+* Billiard is used in and is a dependency for Celery and is maintained
+ by the Celery team.
diff --git a/python/python3-billiard/python3-billiard.SlackBuild b/python/python3-billiard/python3-billiard.SlackBuild
new file mode 100644
index 0000000000..69b1c6c82c
--- /dev/null
+++ b/python/python3-billiard/python3-billiard.SlackBuild
@@ -0,0 +1,77 @@
+#!/bin/bash
+
+# SlackBuild script for billiard.
+# Yth | Pont-en-Royans, France | yth@ythogtha.org
+
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-billiard
+SRCNAM=${PRGNAM#python3-*}
+VERSION=${VERSION:-4.2.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-billiard/python3-billiard.info b/python/python3-billiard/python3-billiard.info
new file mode 100644
index 0000000000..b4d7093cb1
--- /dev/null
+++ b/python/python3-billiard/python3-billiard.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-billiard"
+VERSION="4.2.0"
+HOMEPAGE="https://github.com/celery/billiard"
+DOWNLOAD="https://pypi.python.org/packages/source/b/billiard/billiard-4.2.0.tar.gz"
+MD5SUM="93b1679438c5d24d170ed70ee03cdd53"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Yth - Arnaud"
+EMAIL="yth@ythogtha.org"
diff --git a/python/python3-billiard/slack-desc b/python/python3-billiard/slack-desc
new file mode 100644
index 0000000000..5e55995b97
--- /dev/null
+++ b/python/python3-billiard/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-billiard: python3-billiard (Multiprocessing Pool Extensions)
+python3-billiard:
+python3-billiard: billiard is a fork of the Python 2.7 multiprocessing package.
+python3-billiard:
+python3-billiard: This standalone variant draws its fixes/improvements from
+python3-billiard: python-trunk and provides additional bug fixes and improvements.
+python3-billiard:
+python3-billiard:
+python3-billiard:
+python3-billiard:
+python3-billiard: