summaryrefslogtreecommitdiffstats
path: root/python/python2-xcffib
diff options
context:
space:
mode:
Diffstat (limited to 'python/python2-xcffib')
-rw-r--r--python/python2-xcffib/README6
-rw-r--r--python/python2-xcffib/python2-xcffib.SlackBuild96
-rw-r--r--python/python2-xcffib/python2-xcffib.info10
-rw-r--r--python/python2-xcffib/slack-desc19
4 files changed, 131 insertions, 0 deletions
diff --git a/python/python2-xcffib/README b/python/python2-xcffib/README
new file mode 100644
index 0000000000..8b12921e1a
--- /dev/null
+++ b/python/python2-xcffib/README
@@ -0,0 +1,6 @@
+xcffib is intended to be a (mostly) drop-in replacement for xpyb.
+xpyb has an inactive upstream, several memory leaks, is python2
+only and doesn't have pypy support. xcffib is a binding which
+uses cffi, which mitigates some of the issues described above.
+xcffib also builds bindings for 27 of the 29 (xprint and xkb are
+missing) X extensions in 1.10.
diff --git a/python/python2-xcffib/python2-xcffib.SlackBuild b/python/python2-xcffib/python2-xcffib.SlackBuild
new file mode 100644
index 0000000000..d0abd41ea2
--- /dev/null
+++ b/python/python2-xcffib/python2-xcffib.SlackBuild
@@ -0,0 +1,96 @@
+#!/bin/bash
+
+# Slackware build script for python-xcffib
+
+# Copyright 2016-2019 Dimitris Zlatanidis Orestiada, Greece
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python2-xcffib
+SRCNAM=$( echo $PRGNAM | cut -d- -f2- )
+VERSION=${VERSION:-0.8.1}
+BUILD=${BUILD:-2}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python2 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.md LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python2-xcffib/python2-xcffib.info b/python/python2-xcffib/python2-xcffib.info
new file mode 100644
index 0000000000..d853b392bf
--- /dev/null
+++ b/python/python2-xcffib/python2-xcffib.info
@@ -0,0 +1,10 @@
+PRGNAM="python2-xcffib"
+VERSION="0.8.1"
+HOMEPAGE="https://github.com/tych0/xcffib"
+DOWNLOAD="https://files.pythonhosted.org/packages/16/d2/8658ed194e8b482af8d9ad2c5ddd126f1fb3553659f45be495ded371f3b6/xcffib-0.8.1.tar.gz"
+MD5SUM="0bb35f75ad9ef91bd5adcac8919cf51b"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="cffi"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/python2-xcffib/slack-desc b/python/python2-xcffib/slack-desc
new file mode 100644
index 0000000000..a5c13ce4b3
--- /dev/null
+++ b/python/python2-xcffib/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python2-xcffib: python2-xcffib (XCB python binding)
+python2-xcffib:
+python2-xcffib: xcffib is intended to be a (mostly) drop-in replacement for xpyb.
+python2-xcffib: xpyb has an inactive upstream, several memory leaks, is python2 only
+python2-xcffib: and doesn't have pypy support. xcffib is a binding which uses cffi,
+python2-xcffib: which mitigates some of the issues described above. xcffib also
+python2-xcffib: builds bindings for 27 of the 29 (xprint and xkb are missing)
+python2-xcffib: X extensions in 1.10.
+python2-xcffib:
+python2-xcffib: Homepage: https://github.com/tych0/xcffib
+python2-xcffib: