summaryrefslogtreecommitdiffstats
path: root/python/python-xlib/python-xlib.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-xlib/python-xlib.SlackBuild')
-rw-r--r--python/python-xlib/python-xlib.SlackBuild28
1 files changed, 15 insertions, 13 deletions
diff --git a/python/python-xlib/python-xlib.SlackBuild b/python/python-xlib/python-xlib.SlackBuild
index 0ea9263b3a..a298a8947a 100644
--- a/python/python-xlib/python-xlib.SlackBuild
+++ b/python/python-xlib/python-xlib.SlackBuild
@@ -1,14 +1,17 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for python-xlib
# Written by Vasilis Papavasileiou <el03020 at mail dot ntua dot gr>
-# Copyright 2018-2019 Hunter Sezen California, USA
+# Copyright 2018-2020 Hunter Sezen California, USA
+
+cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python-xlib
-VERSION=${VERSION:-0.25}
+VERSION=${VERSION:-0.26}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -18,7 +21,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -38,14 +48,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Partially revert: fixup metadata
-# Revert: setup: check setuptools is recent enough to support `setup.cfg`
-# https://github.com/python-xlib/python-xlib/commit/22a8e1929ad58b8168bcf5d931e8f6067ebdec0a
-# https://github.com/python-xlib/python-xlib/commit/376b4739cedc4eee32e60e7b158d20ed18dfddc1
-# https://github.com/python-xlib/python-xlib/issues/106
-sed -i 's/\r$//g' setup.py
-patch -p1 < $CWD/setup.patch
-
python setup.py install --root $PKG
# Python 3 support.
@@ -61,4 +63,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE