summaryrefslogtreecommitdiffstats
path: root/python/python-webencodings/python-webencodings.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-webencodings/python-webencodings.SlackBuild')
-rw-r--r--python/python-webencodings/python-webencodings.SlackBuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/python/python-webencodings/python-webencodings.SlackBuild b/python/python-webencodings/python-webencodings.SlackBuild
index fe72b0f16b..a07d9cb7d8 100644
--- a/python/python-webencodings/python-webencodings.SlackBuild
+++ b/python/python-webencodings/python-webencodings.SlackBuild
@@ -2,7 +2,7 @@
#
# SlackBuild for python-webencodings
#
-# Copyright 2017 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2017-2018 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
@@ -23,7 +23,7 @@
PRGNAM=python-webencodings
VERSION=${VERSION:-0.5.1}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -68,7 +68,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true