summaryrefslogtreecommitdiffstats
path: root/python/python-twisted/python-twisted.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-twisted/python-twisted.SlackBuild')
-rw-r--r--python/python-twisted/python-twisted.SlackBuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/python/python-twisted/python-twisted.SlackBuild b/python/python-twisted/python-twisted.SlackBuild
index 594120d8bc..a2256e63b2 100644
--- a/python/python-twisted/python-twisted.SlackBuild
+++ b/python/python-twisted/python-twisted.SlackBuild
@@ -1,9 +1,9 @@
#!/bin/sh
-# Slackware build script for python-twisted.
+# Slackware build script for python-twisted
# Copyright 2009-2011 Marco Bonetti <sid77@slackware.it>
-# Copyright 2012-2015 Markus Reichelt, Stolberg (Rhld), DE
+# Copyright 2012-2016 Markus Reichelt, Aachen, DE
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -28,13 +28,13 @@
PRGNAM=python-twisted
SRCNAM=Twisted
-VERSION=${VERSION:-15.2.1}
+VERSION=${VERSION:-16.4.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -45,8 +45,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -72,7 +72,7 @@ find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
@@ -81,7 +81,7 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- LICENSE NEWS README \
+ LICENSE* NEWS* README* \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild