summaryrefslogtreecommitdiffstats
path: root/python/python-sh
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-sh')
-rw-r--r--python/python-sh/README10
-rw-r--r--python/python-sh/python-sh.SlackBuild22
-rw-r--r--python/python-sh/python-sh.info2
3 files changed, 19 insertions, 15 deletions
diff --git a/python/python-sh/README b/python/python-sh/README
index e1c4d96069..e53ed998eb 100644
--- a/python/python-sh/README
+++ b/python/python-sh/README
@@ -1,12 +1,6 @@
-sh (previously pbs) is a full-fledged subprocess interface for Python that
-allows you to call any program as if it were a function.
+sh (previously pbs) is a full-fledged subprocess interface for Python
+that allows you to call any program as if it were a function.
Eg:
from sh import ifconfig
print(ifconfig("wlan0"))
-
-Optional dependency: python3
-
-Note: Pass PYTHON3=yes to the slackbuild for pyhton 3 support.
-
- # PYTHON3="yes" ./python-sh.SlackBuild
diff --git a/python/python-sh/python-sh.SlackBuild b/python/python-sh/python-sh.SlackBuild
index 031a1c58b8..da402fe38c 100644
--- a/python/python-sh/python-sh.SlackBuild
+++ b/python/python-sh/python-sh.SlackBuild
@@ -1,8 +1,8 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for python-sh
-# Copyright 2012-2018 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2012-2020 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,10 +22,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=python-sh
VERSION=${VERSION:-1.12.14}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -35,7 +38,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -57,7 +67,7 @@ find -L . \
python setup.py install --root=$PKG
-if [ "${PYTHON3:-no}" == "yes" ]; then
+if $(python3 -c 'import sys' 2>/dev/null); then
python3 setup.py install --root=$PKG
fi
@@ -72,4 +82,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python-sh/python-sh.info b/python/python-sh/python-sh.info
index 7df7c7bc06..650d0a4a33 100644
--- a/python/python-sh/python-sh.info
+++ b/python/python-sh/python-sh.info
@@ -1,7 +1,7 @@
PRGNAM="python-sh"
VERSION="1.12.14"
HOMEPAGE="http://amoffat.github.com/sh/index.html"
-DOWNLOAD="https://files.pythonhosted.org/packages/7c/71/199d27d3e7e78bf448bcecae0105a1d5b29173ffd2bbadaa95a74c156770/sh-1.12.14.tar.gz"
+DOWNLOAD="https://pypi.io/packages/source/s/sh/sh-1.12.14.tar.gz"
MD5SUM="a8351aef25d25f707c17e0a7a6280251"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""