summaryrefslogtreecommitdiffstats
path: root/python/python-sh/python-sh.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-sh/python-sh.SlackBuild')
-rw-r--r--python/python-sh/python-sh.SlackBuild22
1 files changed, 16 insertions, 6 deletions
diff --git a/python/python-sh/python-sh.SlackBuild b/python/python-sh/python-sh.SlackBuild
index 031a1c58b8..da402fe38c 100644
--- a/python/python-sh/python-sh.SlackBuild
+++ b/python/python-sh/python-sh.SlackBuild
@@ -1,8 +1,8 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for python-sh
-# Copyright 2012-2018 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2012-2020 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,10 +22,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=python-sh
VERSION=${VERSION:-1.12.14}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -35,7 +38,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -57,7 +67,7 @@ find -L . \
python setup.py install --root=$PKG
-if [ "${PYTHON3:-no}" == "yes" ]; then
+if $(python3 -c 'import sys' 2>/dev/null); then
python3 setup.py install --root=$PKG
fi
@@ -72,4 +82,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE