summaryrefslogtreecommitdiffstats
path: root/python/python-notify2
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-notify2')
-rw-r--r--python/python-notify2/README4
-rw-r--r--python/python-notify2/python-notify2.SlackBuild86
-rw-r--r--python/python-notify2/python-notify2.info10
-rw-r--r--python/python-notify2/slack-desc19
4 files changed, 0 insertions, 119 deletions
diff --git a/python/python-notify2/README b/python/python-notify2/README
deleted file mode 100644
index a1c3e66911..0000000000
--- a/python/python-notify2/README
+++ /dev/null
@@ -1,4 +0,0 @@
-This is a pure-python replacement for notify-python, using
-python-dbus to communicate with the notifications server directly.
-It's compatible with Python 2 and 3, and its callbacks can work
-with Gtk 3 or Qt 4 applications.
diff --git a/python/python-notify2/python-notify2.SlackBuild b/python/python-notify2/python-notify2.SlackBuild
deleted file mode 100644
index 81fbc72fe7..0000000000
--- a/python/python-notify2/python-notify2.SlackBuild
+++ /dev/null
@@ -1,86 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for python-notify2
-
-# Copyright 2015-2018 Dimitris Zlatanidis Orestiada, Greece
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=python-notify2
-SRCNAM=$(echo $PRGNAM | cut -c8-14)
-VERSION=${VERSION:-0.3.1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a PKG-INFO examples/README $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-notify2/python-notify2.info b/python/python-notify2/python-notify2.info
deleted file mode 100644
index 6e1b1b278d..0000000000
--- a/python/python-notify2/python-notify2.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python-notify2"
-VERSION="0.3.1"
-HOMEPAGE="https://bitbucket.org/takluyver/pynotify2"
-DOWNLOAD="https://pypi.python.org/packages/aa/e8/d4b335aa739dc299a77766ecc5f1972d1de1993524aa94acef3219bba315/notify2-0.3.1.tar.gz"
-MD5SUM="ffccaed9330787c7442b453f6520a474"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/python-notify2/slack-desc b/python/python-notify2/slack-desc
deleted file mode 100644
index f7123aedd8..0000000000
--- a/python/python-notify2/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-notify2: python-notify2 (Python interface to DBus notifications)
-python-notify2:
-python-notify2: This is a pure-python replacement for notify-python, using
-python-notify2: python-dbus to communicate with the notifications server directly.
-python-notify2: It's compatible with Python 2 and 3, and its callbacks can work with
-python-notify2: Gtk 3 or Qt 4 applications.
-python-notify2:
-python-notify2: Homepage: https://bitbucket.org/takluyver/pynotify2
-python-notify2:
-python-notify2:
-python-notify2: