summaryrefslogtreecommitdiffstats
path: root/python/python-magick/python-magick.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-magick/python-magick.SlackBuild')
-rw-r--r--python/python-magick/python-magick.SlackBuild18
1 files changed, 11 insertions, 7 deletions
diff --git a/python/python-magick/python-magick.SlackBuild b/python/python-magick/python-magick.SlackBuild
index dd317dbe4c..5ad3eab515 100644
--- a/python/python-magick/python-magick.SlackBuild
+++ b/python/python-magick/python-magick.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=python-magick
SRCNAM=PythonMagick
VERSION=${VERSION:-0.9.8}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -72,13 +72,17 @@ find . \
-exec chmod 644 {} \;
# Provide all objects in PythonMagick
-patch -p1 < $CWD/__init__-fixup
+patch -p1 < $CWD/patches/__init__-fixup
-# Cheat! Achtung!
-sed -i \
- -e "s|in\ python2\.6\ python2\.5|in python2.7 python2.6|" \
- -e "s|PREFIX/lib/python|PREFIX/lib${LIBDIRSUFFIX}/python|" \
- configure
+# Use the default python on the system and fix detection of the python
+# include dir (thanks Gentoo)
+patch -p0 < $CWD/patches/pythonmagick-0.9.1-use_active_python_version.patch
+patch -p0 < $CWD/patches/pythonmagick-0.9.2-fix_detection_of_python_includedir.patch
+
+# We have 1.11.5 so it must suffice
+sed -i "s|1\.12|1.11.5|" configure.ac
+
+autoreconf -fi
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \