summaryrefslogtreecommitdiffstats
path: root/python/python-emoji/python-emoji.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-emoji/python-emoji.SlackBuild')
-rw-r--r--python/python-emoji/python-emoji.SlackBuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/python/python-emoji/python-emoji.SlackBuild b/python/python-emoji/python-emoji.SlackBuild
index 159421a4d3..ea9bddd5c9 100644
--- a/python/python-emoji/python-emoji.SlackBuild
+++ b/python/python-emoji/python-emoji.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python-emoji
-# Copyright 2018 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2018-2019 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
SRCNAM=emoji
PRGNAM=python-$SRCNAM
-VERSION=${VERSION:-0.5.1}
+VERSION=${VERSION:-0.5.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -70,10 +70,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true