summaryrefslogtreecommitdiffstats
path: root/python/python-cached-property
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-cached-property')
-rw-r--r--python/python-cached-property/README1
-rw-r--r--python/python-cached-property/python-cached-property.SlackBuild70
-rw-r--r--python/python-cached-property/python-cached-property.info10
-rw-r--r--python/python-cached-property/slack-desc19
4 files changed, 0 insertions, 100 deletions
diff --git a/python/python-cached-property/README b/python/python-cached-property/README
deleted file mode 100644
index f5f4d6f535..0000000000
--- a/python/python-cached-property/README
+++ /dev/null
@@ -1 +0,0 @@
-A Python decorator for caching properties in classes.
diff --git a/python/python-cached-property/python-cached-property.SlackBuild b/python/python-cached-property/python-cached-property.SlackBuild
deleted file mode 100644
index 27ff44ca75..0000000000
--- a/python/python-cached-property/python-cached-property.SlackBuild
+++ /dev/null
@@ -1,70 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for python-cached-property
-
-# Copyright 2017-2018 Audrius Kažukauskas <audrius@neutrino.lt>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=python-cached-property
-VERSION=${VERSION:-1.4.2}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-SRCNAM="$(printf $PRGNAM | cut -d- -f2-)"
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS.rst HISTORY.rst LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-cached-property/python-cached-property.info b/python/python-cached-property/python-cached-property.info
deleted file mode 100644
index 0e729115c4..0000000000
--- a/python/python-cached-property/python-cached-property.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python-cached-property"
-VERSION="1.4.2"
-HOMEPAGE="https://github.com/pydanny/cached-property"
-DOWNLOAD="https://files.pythonhosted.org/packages/d4/c4/3cc804063fb5f3f63747a68c620145dc54e62b2dd2779f86a477e033fbad/cached-property-1.4.2.tar.gz"
-MD5SUM="e4f2c194492fabd80b353d89198e434d"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Audrius Kažukauskas"
-EMAIL="audrius@neutrino.lt"
diff --git a/python/python-cached-property/slack-desc b/python/python-cached-property/slack-desc
deleted file mode 100644
index eeb010102d..0000000000
--- a/python/python-cached-property/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-cached-property: python-cached-property (decorator for caching properties in classes)
-python-cached-property:
-python-cached-property: Homepage: https://github.com/pydanny/cached-property
-python-cached-property:
-python-cached-property:
-python-cached-property:
-python-cached-property:
-python-cached-property:
-python-cached-property:
-python-cached-property:
-python-cached-property: