summaryrefslogtreecommitdiffstats
path: root/python/python-autobahn
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-autobahn')
-rw-r--r--python/python-autobahn/README5
-rw-r--r--python/python-autobahn/python-autobahn.SlackBuild87
-rw-r--r--python/python-autobahn/python-autobahn.info10
-rw-r--r--python/python-autobahn/slack-desc19
4 files changed, 0 insertions, 121 deletions
diff --git a/python/python-autobahn/README b/python/python-autobahn/README
deleted file mode 100644
index 385ab1dc96..0000000000
--- a/python/python-autobahn/README
+++ /dev/null
@@ -1,5 +0,0 @@
-Autobahn|Python is a subproject of Autobahn and provides open-source
-implementations of the WebSocket Protocol and the Web Application
-Messaging Protocol (WAMP) for Python. WebSocket allows bidirectional
-real-time messaging on the Web and beyond, while WAMP adds real-time
-application communication on top of WebSocket.
diff --git a/python/python-autobahn/python-autobahn.SlackBuild b/python/python-autobahn/python-autobahn.SlackBuild
deleted file mode 100644
index 929114b335..0000000000
--- a/python/python-autobahn/python-autobahn.SlackBuild
+++ /dev/null
@@ -1,87 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for python-autobahn
-
-# Copyright 2016 David Spencer, Baildon, West Yorkshire, U.K.
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=python-autobahn
-VERSION=${VERSION:-18.11.1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-SRCNAM="$(printf $PRGNAM | cut -d- -f2-)"
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-autobahn/python-autobahn.info b/python/python-autobahn/python-autobahn.info
deleted file mode 100644
index 9900faebd4..0000000000
--- a/python/python-autobahn/python-autobahn.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python-autobahn"
-VERSION="18.11.1"
-HOMEPAGE="https://crossbar.io/autobahn/"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/a/autobahn/autobahn-18.11.1.tar.gz"
-MD5SUM="a3a0648371b41328282a9ab7fe48ccbe"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="python-txaio"
-MAINTAINER="David Spencer"
-EMAIL="baildon.research@googlemail.com"
diff --git a/python/python-autobahn/slack-desc b/python/python-autobahn/slack-desc
deleted file mode 100644
index ddc70010c7..0000000000
--- a/python/python-autobahn/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-autobahn: python-autobahn (Websocket and WAMP for Python)
-python-autobahn:
-python-autobahn: Autobahn|Python is a subproject of Autobahn and provides open-source
-python-autobahn: implementations of the WebSocket Protocol and the Web Application
-python-autobahn: Messaging Protocol (WAMP) for Python.
-python-autobahn:
-python-autobahn: http://crossbar.io/autobahn/
-python-autobahn:
-python-autobahn:
-python-autobahn:
-python-autobahn: