summaryrefslogtreecommitdiffstats
path: root/python/python-authres/python-authres.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-authres/python-authres.SlackBuild')
-rw-r--r--python/python-authres/python-authres.SlackBuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/python/python-authres/python-authres.SlackBuild b/python/python-authres/python-authres.SlackBuild
index f4354c00f7..1f4935f600 100644
--- a/python/python-authres/python-authres.SlackBuild
+++ b/python/python-authres/python-authres.SlackBuild
@@ -52,10 +52,10 @@ tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
/usr/bin/python setup.py install --root $PKG
@@ -66,5 +66,8 @@ mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a CHANGES COPYING README $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}