summaryrefslogtreecommitdiffstats
path: root/python/pygame/pygame.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/pygame/pygame.SlackBuild')
-rw-r--r--python/pygame/pygame.SlackBuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/python/pygame/pygame.SlackBuild b/python/pygame/pygame.SlackBuild
index 8e8ac32b3c..36c5397ee2 100644
--- a/python/pygame/pygame.SlackBuild
+++ b/python/pygame/pygame.SlackBuild
@@ -6,7 +6,7 @@
# Modified by the SlackBuilds.org project
# Maintained by Bojan Popovic (bocke@slackware-srbija.org), 2014-2017
# Contribution by B.Watson (yalhcru@gmail.com), 11 apr. 2017.
-# Copyright 2017-2018 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2017-2019 Dimitris Zlatanidis Orestiada, Greece
#
# All rights reserved.
#
@@ -28,7 +28,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pygame
-VERSION=${VERSION:-1.9.4}
+VERSION=${VERSION:-1.9.6}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -75,7 +75,10 @@ find -L . \
# TLDR: Stops packaging scripts from messing with a local PyGame install.
sed -i '/^if "install"/,$d' setup.py
-python -u config.py
+# Fix warning message for missings dependencies
+patch -p1 < $CWD/config_unix.patch
+
+python -u buildconfig/config.py
CFLAGS="$SLKCFLAGS" \
python setup.py install --root=$PKG
@@ -83,7 +86,7 @@ find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a WHATSNEW README.rst LGPL $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst docs/LGPL $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install