summaryrefslogtreecommitdiffstats
path: root/python/pygame/pygame.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/pygame/pygame.SlackBuild')
-rw-r--r--python/pygame/pygame.SlackBuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/python/pygame/pygame.SlackBuild b/python/pygame/pygame.SlackBuild
index 36c5397ee2..89cd4697eb 100644
--- a/python/pygame/pygame.SlackBuild
+++ b/python/pygame/pygame.SlackBuild
@@ -82,6 +82,12 @@ python -u buildconfig/config.py
CFLAGS="$SLKCFLAGS" \
python setup.py install --root=$PKG
+# Pythonn 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ CFLAGS="$SLKCFLAGS" \
+python3 setup.py install --root=$PKG
+fi
+
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true