summaryrefslogtreecommitdiffstats
path: root/python/pycassa/pycassa.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/pycassa/pycassa.SlackBuild')
-rw-r--r--python/pycassa/pycassa.SlackBuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/python/pycassa/pycassa.SlackBuild b/python/pycassa/pycassa.SlackBuild
index ea09e4b3db..a1792b1d19 100644
--- a/python/pycassa/pycassa.SlackBuild
+++ b/python/pycassa/pycassa.SlackBuild
@@ -2,11 +2,12 @@
# Slackware build script for pycassa
-# Copyright 2012, Nikolay Korotkiy <sikmir@gmail.com>
+# Copyright 2012-2016, Nikolay Korotkiy <sikmir@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
+#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
@@ -22,13 +23,13 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pycassa
-VERSION=${VERSION:-1.7.2}
+VERSION=${VERSION:-1.11.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -49,10 +50,10 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG