summaryrefslogtreecommitdiffstats
path: root/python/prompt_toolkit1
diff options
context:
space:
mode:
Diffstat (limited to 'python/prompt_toolkit1')
-rw-r--r--python/prompt_toolkit1/README5
-rw-r--r--python/prompt_toolkit1/prompt_toolkit1.SlackBuild96
-rw-r--r--python/prompt_toolkit1/prompt_toolkit1.info10
-rw-r--r--python/prompt_toolkit1/slack-desc19
4 files changed, 0 insertions, 130 deletions
diff --git a/python/prompt_toolkit1/README b/python/prompt_toolkit1/README
deleted file mode 100644
index 282080066b..0000000000
--- a/python/prompt_toolkit1/README
+++ /dev/null
@@ -1,5 +0,0 @@
-Library for building powerful interactive command lines in Python.
-prompt_toolkit could be a replacement for GNU readline, but it can
-be much more than that.
-
-This package conflict with prompt_toolkit please don't install both.
diff --git a/python/prompt_toolkit1/prompt_toolkit1.SlackBuild b/python/prompt_toolkit1/prompt_toolkit1.SlackBuild
deleted file mode 100644
index 43e8c4f30b..0000000000
--- a/python/prompt_toolkit1/prompt_toolkit1.SlackBuild
+++ /dev/null
@@ -1,96 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for prompt_toolkit1
-
-# Copyright 2018 Dimitris Zlatanidis Orestiada, Greece
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=prompt_toolkit1
-SRCNAM=prompt_toolkit
-VERSION=${VERSION:-1.0.15}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python2 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.rst PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/prompt_toolkit1/prompt_toolkit1.info b/python/prompt_toolkit1/prompt_toolkit1.info
deleted file mode 100644
index bb87ac1b7c..0000000000
--- a/python/prompt_toolkit1/prompt_toolkit1.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="prompt_toolkit1"
-VERSION="1.0.15"
-HOMEPAGE="https://github.com/jonathanslenders/python-prompt-toolkit"
-DOWNLOAD="https://files.pythonhosted.org/packages/8a/ad/cf6b128866e78ad6d7f1dc5b7f99885fb813393d9860778b2984582e81b5/prompt_toolkit-1.0.15.tar.gz"
-MD5SUM="8fe70295006dbc8afedd43e5eba99032"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="wcwidth"
-MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/prompt_toolkit1/slack-desc b/python/prompt_toolkit1/slack-desc
deleted file mode 100644
index d385bb638e..0000000000
--- a/python/prompt_toolkit1/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-prompt_toolkit1: prompt_toolkit1 (interactive command lines)
-prompt_toolkit1:
-prompt_toolkit1: Library for building powerful interactive command lines in Python.
-prompt_toolkit1: prompt_toolkit could be a replacement for GNU readline, but it can be
-prompt_toolkit1: much more than that.
-prompt_toolkit1:
-prompt_toolkit1: Homepage: https://github.com/jonathanslenders/python-prompt-toolkit
-prompt_toolkit1:
-prompt_toolkit1:
-prompt_toolkit1:
-prompt_toolkit1: