summaryrefslogtreecommitdiffstats
path: root/python/planes
diff options
context:
space:
mode:
Diffstat (limited to 'python/planes')
-rw-r--r--python/planes/README9
-rw-r--r--python/planes/planes.SlackBuild71
-rw-r--r--python/planes/planes.info10
-rw-r--r--python/planes/slack-desc19
4 files changed, 109 insertions, 0 deletions
diff --git a/python/planes/README b/python/planes/README
new file mode 100644
index 0000000000..1cef88d882
--- /dev/null
+++ b/python/planes/README
@@ -0,0 +1,9 @@
+planes is a hierarchical surface framework for PyGame by Florian Berger.
+
+The planes module introduces the "Plane" class which extends PyGame's
+"Surface" functionality, offering a hierarchy of mouse-sensitive, draggable
+Surfaces that can be used as sprites, windows, icons or other interactive
+elements.
+
+In addition, the planes.gui module uses planes to provide basic GUI
+elements like container, label, text box, option list and button.
diff --git a/python/planes/planes.SlackBuild b/python/planes/planes.SlackBuild
new file mode 100644
index 0000000000..a296bd7d99
--- /dev/null
+++ b/python/planes/planes.SlackBuild
@@ -0,0 +1,71 @@
+#!/bin/sh
+# Slackware build script for planes
+# Copyright 2013 Klaatu klaatu@member.fsf.org
+#
+# GNU All-Permissive License
+# Copying and distribution of this file, with or without modification,
+# are permitted in any medium without royalty provided the copyright
+# notice and this notice are preserved. This file is offered as-is,
+# without any warranty.
+
+PRGNAM=planes
+VERSION=${VERSION:-0.6.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+unzip $CWD/$PRGNAM-$VERSION.zip -d $TMP
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/planes/planes.info b/python/planes/planes.info
new file mode 100644
index 0000000000..802ea1bc2d
--- /dev/null
+++ b/python/planes/planes.info
@@ -0,0 +1,10 @@
+PRGNAM="planes"
+VERSION="0.6.0"
+HOMEPAGE="http://florian-berger.de/en/software/planes"
+DOWNLOAD="http://static.florian-berger.de/planes-0.6.0.zip"
+MD5SUM="3cd067054cc88913ed3541cf30c060a3"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pygame"
+MAINTAINER="klaatu"
+EMAIL="klaatu@member.fsf.org"
diff --git a/python/planes/slack-desc b/python/planes/slack-desc
new file mode 100644
index 0000000000..66537b3ce0
--- /dev/null
+++ b/python/planes/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+planes: planes (surface framework for Pygame)
+planes:
+planes: The planes module introduces the "Plane" class which extends PyGame's
+planes: "Surface" functionality, offering a hierarchy of mouse-sensitive,
+planes: draggable Surfaces that can be used as sprites, windows, icons or
+planes: other interactive elements.
+planes:
+planes: Compatible with Python 2.x and Python 3.x
+planes:
+planes:
+planes: \ No newline at end of file