summaryrefslogtreecommitdiffstats
path: root/python/phply/phply.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/phply/phply.SlackBuild')
-rw-r--r--python/phply/phply.SlackBuild16
1 files changed, 13 insertions, 3 deletions
diff --git a/python/phply/phply.SlackBuild b/python/phply/phply.SlackBuild
index 69533a2646..e932e1c906 100644
--- a/python/phply/phply.SlackBuild
+++ b/python/phply/phply.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for phply
-# Copyright 2015-2017 Brenton Earl <brent@exitstatusone.com>
+# Copyright 2015-2018 Brenton Earl <brent@exitstatusone.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=phply
-VERSION=${VERSION:-1.0.0}
+VERSION=${VERSION:-1.2.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -69,13 +69,23 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+python setup.py test
python setup.py install --root=$PKG
+# Python 3 support.
+# Be aware that the python3 tests downloads a
+# newer version of nose in /tmp to succeed.
+# This newer version of nose does not get installed on your system.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py test
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
+cp -ar README* LICENSE AUTHORS tools/ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
cat $CWD/README.Slackware > $PKG/usr/doc/$PRGNAM-$VERSION/README.Slackware