summaryrefslogtreecommitdiffstats
path: root/python/phply/phply.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/phply/phply.SlackBuild')
-rw-r--r--python/phply/phply.SlackBuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/python/phply/phply.SlackBuild b/python/phply/phply.SlackBuild
index a1b897e3e3..69533a2646 100644
--- a/python/phply/phply.SlackBuild
+++ b/python/phply/phply.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for phply
-# Copyright 2015-2016 Brenton Earl <brent@exitstatusone.com>
+# Copyright 2015-2017 Brenton Earl <brent@exitstatusone.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=phply
-VERSION=${VERSION:-0.9.1}
+VERSION=${VERSION:-1.0.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -69,17 +69,15 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# make setup.py include scripts in $PRGNAM-$VERSION/tools/
-patch -p1 --verbose < $CWD/phply-setup.py.diff
-
python setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS LICENSE PKG-INFO README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+cat $CWD/README.Slackware > $PKG/usr/doc/$PRGNAM-$VERSION/README.Slackware
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc