summaryrefslogtreecommitdiffstats
path: root/python/netifaces
diff options
context:
space:
mode:
Diffstat (limited to 'python/netifaces')
-rw-r--r--python/netifaces/README7
-rw-r--r--python/netifaces/netifaces.SlackBuild75
-rw-r--r--python/netifaces/netifaces.info10
-rw-r--r--python/netifaces/slack-desc19
4 files changed, 0 insertions, 111 deletions
diff --git a/python/netifaces/README b/python/netifaces/README
deleted file mode 100644
index 1e3b44c2e5..0000000000
--- a/python/netifaces/README
+++ /dev/null
@@ -1,7 +0,0 @@
-Portable module to access network interface information in Python.
-
-Optional dependencies: python3 and Sphinx
-
-Note: To install python3 bindings pass PYTHON3=yes to the slackbuild.
-
- # PYTHON3=yes ./netifaces.SlackBuild
diff --git a/python/netifaces/netifaces.SlackBuild b/python/netifaces/netifaces.SlackBuild
deleted file mode 100644
index 3cbba9e12c..0000000000
--- a/python/netifaces/netifaces.SlackBuild
+++ /dev/null
@@ -1,75 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for netifaces
-
-# Copyright 2012-2019 Larry Hajali <larryhaja[at]gmail[dot]com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=netifaces
-VERSION=${VERSION:-0.10.9}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-if [ "${PYTHON3:-no}" == "yes" ]; then
- python3 setup.py install --root=$PKG
-fi
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a PKG-INFO README.rst $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/netifaces/netifaces.info b/python/netifaces/netifaces.info
deleted file mode 100644
index e86a8e5791..0000000000
--- a/python/netifaces/netifaces.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="netifaces"
-VERSION="0.10.9"
-HOMEPAGE="https://alastairs-place.net/projects/netifaces/"
-DOWNLOAD="https://pypi.io/packages/source/n/netifaces/netifaces-0.10.9.tar.gz"
-MD5SUM="de92cc322b4f56047c073f802ad77860"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Larry Hajali"
-EMAIL="larryhaja[at]gmail[dot]com"
diff --git a/python/netifaces/slack-desc b/python/netifaces/slack-desc
deleted file mode 100644
index 93d364e2a6..0000000000
--- a/python/netifaces/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-netifaces: netifaces (python module to query netif info)
-netifaces:
-netifaces: Portable module to access network interface information in Python.
-netifaces:
-netifaces: Homepage: https://alastairs-place.net/projects/netifaces/
-netifaces:
-netifaces:
-netifaces:
-netifaces:
-netifaces:
-netifaces: