summaryrefslogtreecommitdiffstats
path: root/python/ipython/ipython.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/ipython/ipython.SlackBuild')
-rw-r--r--python/ipython/ipython.SlackBuild32
1 files changed, 20 insertions, 12 deletions
diff --git a/python/ipython/ipython.SlackBuild b/python/ipython/ipython.SlackBuild
index 4af705431e..faffc3da6d 100644
--- a/python/ipython/ipython.SlackBuild
+++ b/python/ipython/ipython.SlackBuild
@@ -1,9 +1,11 @@
-#!/bin/sh
+#!/bin/bash
-# SlackBuild for IPython
+# SlackBuild for ipython
-# Copyright 2008-2011 Carlos Corbacho <carlos@strangeworlds.co.uk>
-# Copyright 2013-2018 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2008-2011 Carlos Corbacho <carlos@strangeworlds.co.uk>
+# Copyright 2013-2021 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2022-2023 Isaac Yu <isaacyu@protonmail.com>
+# Copyright 2023-2024 Jeremy Hansen <jebrhansen+SBo@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,10 +25,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=ipython
-VERSION=${VERSION:-5.8.0}
+VERSION=${VERSION:-8.18.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -36,11 +41,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-DOCS=${DOCS:-no}
set -e
@@ -57,7 +65,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root="$PKG"
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -67,11 +75,11 @@ find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
# Delete now empty directory
-rm -rf $PKG/usr/share
+rmdir $PKG/usr/share
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp \
- COPYING.rst README.rst \
+cp -a \
+ COPYING.rst LICENSE long_description.rst README.rst \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
@@ -79,4 +87,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE