summaryrefslogtreecommitdiffstats
path: root/python/google-apputils
diff options
context:
space:
mode:
Diffstat (limited to 'python/google-apputils')
-rw-r--r--python/google-apputils/README5
-rw-r--r--python/google-apputils/google-apputils.SlackBuild75
-rw-r--r--python/google-apputils/google-apputils.info10
-rw-r--r--python/google-apputils/slack-desc19
4 files changed, 0 insertions, 109 deletions
diff --git a/python/google-apputils/README b/python/google-apputils/README
deleted file mode 100644
index dd787f810e..0000000000
--- a/python/google-apputils/README
+++ /dev/null
@@ -1,5 +0,0 @@
-google-apputils (Google Application Utilities for Python)
-
-This project is a small collection of utilities for building Python
-applications. It includes some of the same set of utilities used
-to build and run internal Python apps at Google.
diff --git a/python/google-apputils/google-apputils.SlackBuild b/python/google-apputils/google-apputils.SlackBuild
deleted file mode 100644
index 96fd672f4b..0000000000
--- a/python/google-apputils/google-apputils.SlackBuild
+++ /dev/null
@@ -1,75 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for google-apputils
-
-# Copyright 2017 Matt Dinslage <daedra1980[at]gmail[dot]com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=google-apputils
-VERSION=${VERSION:-0.4.2}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE README $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/google-apputils/google-apputils.info b/python/google-apputils/google-apputils.info
deleted file mode 100644
index be0c30d237..0000000000
--- a/python/google-apputils/google-apputils.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="google-apputils"
-VERSION="0.4.2"
-HOMEPAGE="https://github.com/google/google-apputils"
-DOWNLOAD="https://distfiles.macports.org/py-google-apputils/google-apputils-0.4.2.tar.gz"
-MD5SUM="fb9fadf621dbecf28c8dabb5fe37ddb3"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="M.Dinslage"
-EMAIL="daedra1980@gmail.com"
diff --git a/python/google-apputils/slack-desc b/python/google-apputils/slack-desc
deleted file mode 100644
index fc11cd2245..0000000000
--- a/python/google-apputils/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-google-apputils: google-apputils (Google Application Utilities for Python)
-google-apputils:
-google-apputils: This project is a small collection of utilities for building Python
-google-apputils: applications. It includes some of the same set of utilities used
-google-apputils: to build and run internal Python apps at Google.
-google-apputils:
-google-apputils:
-google-apputils:
-google-apputils:
-google-apputils:
-google-apputils: