summaryrefslogtreecommitdiffstats
path: root/python/flake8/flake8.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/flake8/flake8.SlackBuild')
-rw-r--r--python/flake8/flake8.SlackBuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/python/flake8/flake8.SlackBuild b/python/flake8/flake8.SlackBuild
index 6fcb85e3be..6a9b7bfd70 100644
--- a/python/flake8/flake8.SlackBuild
+++ b/python/flake8/flake8.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for flake8
-# Copyright 2014-2016 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2014-2017 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=flake8
-VERSION=${VERSION:-3.2.1}
+VERSION=${VERSION:-3.5.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -69,6 +69,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Ignores setuptools version, it works for me
+sed -i "s/setuptools >= 30\",/\"/" setup.py
+
python setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \