summaryrefslogtreecommitdiffstats
path: root/python/dulwich/dulwich.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/dulwich/dulwich.SlackBuild')
-rw-r--r--python/dulwich/dulwich.SlackBuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/python/dulwich/dulwich.SlackBuild b/python/dulwich/dulwich.SlackBuild
index 714e5bf381..4c07ddc556 100644
--- a/python/dulwich/dulwich.SlackBuild
+++ b/python/dulwich/dulwich.SlackBuild
@@ -57,6 +57,11 @@ find -L . \
python setup.py install --root=$PKG
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true