summaryrefslogtreecommitdiffstats
path: root/python/click
diff options
context:
space:
mode:
Diffstat (limited to 'python/click')
-rw-r--r--python/click/README23
-rw-r--r--python/click/click.SlackBuild40
-rw-r--r--python/click/click.info10
3 files changed, 44 insertions, 29 deletions
diff --git a/python/click/README b/python/click/README
index c402f0ec11..335070ddc9 100644
--- a/python/click/README
+++ b/python/click/README
@@ -1,10 +1,17 @@
$ click_
- Click is a Python package for creating beautiful command line interfaces
- in a composable way with as little code as necessary. It's the "Command
- Line Interface Creation Kit". It's highly configurable but comes with
- sensible defaults out of the box.
-
- It aims to make the process of writing command line tools quick and fun
- while also preventing any frustration caused by the inability to implement
- an intended CLI API
+Click is a Python package for creating beautiful command line interfaces
+in a composable way with as little code as necessary. It's the "Command
+Line Interface Creation Kit". It's highly configurable but comes with
+sensible defaults out of the box.
+
+It aims to make the process of writing command line tools quick and
+fun while also preventing any frustration caused by the inability to
+implement an intended CLI API.
+
+NOTE:
+-Use click-legacy7 if you need click<=8 and/or python2 support
+
+IMPORTANT:
+-Conflicts with click-legacy7 and both cannot be installed at the same
+ time.
diff --git a/python/click/click.SlackBuild b/python/click/click.SlackBuild
index 436aaf204e..b72b7dc76b 100644
--- a/python/click/click.SlackBuild
+++ b/python/click/click.SlackBuild
@@ -1,7 +1,8 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for click
+# Copyright 2022-23 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# Copyright 2014-2018 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
@@ -22,11 +23,16 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220512 46and2: Updated version, new maintainer.
+# - Removed python2 support
+
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=click
-SRCNAM=Click
-VERSION=${VERSION:-7.0}
+VERSION=${VERSION:-8.1.7}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -36,7 +42,11 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -50,6 +60,9 @@ elif [ "$ARCH" = "i686" ]; then
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
@@ -60,22 +73,17 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-python setup.py install --root=$PKG
-
-# Python 3 support.
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -88,4 +96,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/click/click.info b/python/click/click.info
index 55e37edd36..8a6db6e40e 100644
--- a/python/click/click.info
+++ b/python/click/click.info
@@ -1,10 +1,10 @@
PRGNAM="click"
-VERSION="7.0"
+VERSION="8.1.7"
HOMEPAGE="https://github.com/mitsuhiko/click"
-DOWNLOAD="https://files.pythonhosted.org/packages/f8/5c/f60e9d8a1e77005f664b76ff8aeaee5bc05d0a91798afd7f53fc998dbc47/Click-7.0.tar.gz"
-MD5SUM="7f53d50f7b7373ebc7963f9ff697450a"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/c/click/click-8.1.7.tar.gz"
+MD5SUM="7c3b52c56fd30699f453a7dc7b42cecb"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
-MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
+MAINTAINER="fourtysixandtwo"
+EMAIL="fourtysixandtwo@sliderr.net"