summaryrefslogtreecommitdiffstats
path: root/python/blink-qt
diff options
context:
space:
mode:
Diffstat (limited to 'python/blink-qt')
-rw-r--r--python/blink-qt/README11
-rw-r--r--python/blink-qt/blink-qt.SlackBuild109
-rw-r--r--python/blink-qt/blink-qt.info10
-rw-r--r--python/blink-qt/doinst.sh3
-rw-r--r--python/blink-qt/slack-desc19
5 files changed, 152 insertions, 0 deletions
diff --git a/python/blink-qt/README b/python/blink-qt/README
new file mode 100644
index 0000000000..ec4881b426
--- /dev/null
+++ b/python/blink-qt/README
@@ -0,0 +1,11 @@
+Blink Qt
+--------
+
+This is Blink Qt, a state of the art, easy to use SIP client for Linux
+and other operating systems that support Python 3 and Qt 5.
+
+Homepage: http://icanblink.com
+
+Warning: this build is working and calling fine, but there is some
+problem with non-lating contacts in the Google address book. YMMV,
+patches welcome.
diff --git a/python/blink-qt/blink-qt.SlackBuild b/python/blink-qt/blink-qt.SlackBuild
new file mode 100644
index 0000000000..39dc764026
--- /dev/null
+++ b/python/blink-qt/blink-qt.SlackBuild
@@ -0,0 +1,109 @@
+#!/bin/bash
+
+# Slackware build script for blink-qt
+
+# Copyright 2023, Lockywolf
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=blink-qt
+VERSION=${VERSION:-5.6.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+sed -i '2a#cython: language_level=3' setup.py
+
+python3 -m build --wheel --no-isolation
+python3 -m installer --destdir "$PKG" dist/*.whl
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+install -Dm644 "debian/blink.desktop" "$PKG/usr/share/applications/blink.desktop"
+mkdir -p $PKG/usr/man/man1
+cat debian/blink.1 | gzip > $PKG/usr/man/man1/blink.1.gz
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+README LICENSE Notes TODO docs \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/blink-qt/blink-qt.info b/python/blink-qt/blink-qt.info
new file mode 100644
index 0000000000..78bc13bd32
--- /dev/null
+++ b/python/blink-qt/blink-qt.info
@@ -0,0 +1,10 @@
+PRGNAM="blink-qt"
+VERSION="5.6.0"
+HOMEPAGE="https://icanblink.com"
+DOWNLOAD="https://github.com/AGProjects/blink-qt/archive/5.6.0/blink-qt-5.6.0.tar.gz"
+MD5SUM="7bcff92335d1be97820fc1d9327445c2"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3-sipsimple python3-google-api-python-client python3-google-python-api-core python-uritemplate python3-google-auth-library-python python3-oauth2client python3-pgpy python3-pydispatcher"
+MAINTAINER="Lockywolf"
+EMAIL="for_sbo.blink-qt_2023-09-22@lockywolf.net"
diff --git a/python/blink-qt/doinst.sh b/python/blink-qt/doinst.sh
new file mode 100644
index 0000000000..5fb28930db
--- /dev/null
+++ b/python/blink-qt/doinst.sh
@@ -0,0 +1,3 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
diff --git a/python/blink-qt/slack-desc b/python/blink-qt/slack-desc
new file mode 100644
index 0000000000..0b0a6057a4
--- /dev/null
+++ b/python/blink-qt/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+blink-qt: blink-qt (SIP client using Python3 and Qt)
+blink-qt:
+blink-qt: This is Blink Qt, a state of the art, easy to use SIP client for
+blink-qt: Linux and other operating systems that support Python 3 and Qt.
+blink-qt:
+blink-qt:
+blink-qt:
+blink-qt:
+blink-qt:
+blink-qt:
+blink-qt: