summaryrefslogtreecommitdiffstats
path: root/python/Scrapy
diff options
context:
space:
mode:
Diffstat (limited to 'python/Scrapy')
-rw-r--r--python/Scrapy/README4
-rw-r--r--python/Scrapy/Scrapy.SlackBuild85
-rw-r--r--python/Scrapy/Scrapy.info10
-rw-r--r--python/Scrapy/slack-desc19
4 files changed, 0 insertions, 118 deletions
diff --git a/python/Scrapy/README b/python/Scrapy/README
deleted file mode 100644
index 590011ef5d..0000000000
--- a/python/Scrapy/README
+++ /dev/null
@@ -1,4 +0,0 @@
-Scrapy is a fast high-level web crawling and web scraping framework,
-used to crawl websites and extract structured data from their pages.
-It can be used for a wide range of purposes, from data mining to
-monitoring and automated testing.
diff --git a/python/Scrapy/Scrapy.SlackBuild b/python/Scrapy/Scrapy.SlackBuild
deleted file mode 100644
index b3e681ad1c..0000000000
--- a/python/Scrapy/Scrapy.SlackBuild
+++ /dev/null
@@ -1,85 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for Scrapy
-
-# Copyright 2016-2019 Dimitris Zlatanidis Orestiada, Greece
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=Scrapy
-VERSION=${VERSION:-1.7.3}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS INSTALL LICENSE docs/*.rst $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/Scrapy/Scrapy.info b/python/Scrapy/Scrapy.info
deleted file mode 100644
index 9d82e88269..0000000000
--- a/python/Scrapy/Scrapy.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="Scrapy"
-VERSION="1.7.3"
-HOMEPAGE="https://scrapy.org/"
-DOWNLOAD="https://files.pythonhosted.org/packages/a9/12/aa1cbcb81820f1216dc7ac5d28785334f5b5bf0eaf73294ee4026ab7db26/Scrapy-1.7.3.tar.gz"
-MD5SUM="4d209cad26d8f67aace78fea7c3fd5d3"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="python-twisted queuelib parsel PyDispatcher service_identity"
-MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/Scrapy/slack-desc b/python/Scrapy/slack-desc
deleted file mode 100644
index 7cfbe358fb..0000000000
--- a/python/Scrapy/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-Scrapy: Scrapy (Web Scraping framework)
-Scrapy:
-Scrapy: An open source and collaborative framework for extracting the data
-Scrapy: you need from websites. In a fast, simple, yet extensible way.
-Scrapy:
-Scrapy: Homepage: https://scrapy.org/
-Scrapy:
-Scrapy:
-Scrapy:
-Scrapy:
-Scrapy: