summaryrefslogtreecommitdiffstats
path: root/office/zim/zim.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'office/zim/zim.SlackBuild')
-rw-r--r--office/zim/zim.SlackBuild22
1 files changed, 8 insertions, 14 deletions
diff --git a/office/zim/zim.SlackBuild b/office/zim/zim.SlackBuild
index c924515c04..5cd8008e99 100644
--- a/office/zim/zim.SlackBuild
+++ b/office/zim/zim.SlackBuild
@@ -2,8 +2,9 @@
# Slackware build script for zim
-# Copyright 2013 Michael Ren <micron33@gmail.com>
+# Copyright 2019 Andrew Payne <phalange@komputermatrix.com>
# Copyright 2015-2017 Brenton Earl <brent@exitstatusone.com>
+# Copyright 2013 Michael Ren <micron33@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +25,8 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=zim
-VERSION=${VERSION:-0.68}
+SRCNAM=zim-desktop-wiki
+VERSION=${VERSION:-0.71.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -41,7 +43,7 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-DOCS="CHANGELOG.txt LICENSE.txt PKG-INFO README.txt"
+DOCS="CHANGELOG.md CONTRIBUTING.md LICENSE PLUGIN_WRITING.md README.md"
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
@@ -63,8 +65,8 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -72,21 +74,13 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# zim's setup.py subclasses distutil's install class, adding a flag to disable
-# running update-desktop-database and update-mime-database during the install
-# ("automation"), hence --skip-xdg-cmd
-python setup.py install --root=$PKG --skip-xdg-cmd
-
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-mv $PKG/usr/share/man $PKG/usr
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+DESTDIR="$PKG" ./setup.py install
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/README.Plugins > $PKG/usr/doc/$PRGNAM-$VERSION/README.Plugins
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install