summaryrefslogtreecommitdiffstats
path: root/office/wammu
diff options
context:
space:
mode:
Diffstat (limited to 'office/wammu')
-rw-r--r--office/wammu/README4
-rw-r--r--office/wammu/slack-desc2
-rw-r--r--office/wammu/wammu.SlackBuild42
-rw-r--r--office/wammu/wammu.info10
4 files changed, 34 insertions, 24 deletions
diff --git a/office/wammu/README b/office/wammu/README
index 8f56f6c05d..2340e2d541 100644
--- a/office/wammu/README
+++ b/office/wammu/README
@@ -1,4 +1,4 @@
-Mobile phone manager using Gammu as it's backend. It works with any
+Mobile phone manager using Gammu as its backend. It works with any
phone Gammu supports - many Nokias, Siemens, Alcatel, ...
-pybluez is an optional dependency (for bluetooth support).
+python2-pybluez is an optional dependency (for bluetooth support).
diff --git a/office/wammu/slack-desc b/office/wammu/slack-desc
index f2ebc861aa..dcb2222616 100644
--- a/office/wammu/slack-desc
+++ b/office/wammu/slack-desc
@@ -8,7 +8,7 @@
|-----handy-ruler------------------------------------------------------|
wammu: wammu (Mobile-phone manager)
wammu:
-wammu: Mobile phone manager using Gammu as it's backend. It works with any
+wammu: Mobile phone manager using Gammu as its backend. It works with any
wammu: phone Gammu supports - many Nokias, Siemens, Alcatel, ...
wammu:
wammu: Homepage: https://wammu.eu/wammu/
diff --git a/office/wammu/wammu.SlackBuild b/office/wammu/wammu.SlackBuild
index 284b1d3490..28cd6bed6b 100644
--- a/office/wammu/wammu.SlackBuild
+++ b/office/wammu/wammu.SlackBuild
@@ -1,8 +1,8 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for wammu
-# Copyright 2009-2017 Heinz Wiesinger, Amsterdam, The Netherlands
+# Copyright 2009-2021 Heinz Wiesinger, Amsterdam, The Netherlands
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -11,21 +11,24 @@
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=wammu
-VERSION=${VERSION:-0.43}
+VERSION=${VERSION:-0.44}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -35,7 +38,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -69,7 +79,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
mv $PKG/usr/share/man $PKG/usr/man
@@ -88,4 +98,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/office/wammu/wammu.info b/office/wammu/wammu.info
index 9b3dcd105c..d4571a7025 100644
--- a/office/wammu/wammu.info
+++ b/office/wammu/wammu.info
@@ -1,10 +1,10 @@
PRGNAM="wammu"
-VERSION="0.43"
+VERSION="0.44"
HOMEPAGE="https://wammu.eu/wammu/"
-DOWNLOAD="https://dl.cihar.com/wammu/v0/wammu-0.43.tar.xz"
-MD5SUM="b4adfb54323e0baeddb5775511320ae4"
+DOWNLOAD="https://dl.cihar.com/wammu/v0/wammu-0.44.tar.xz"
+MD5SUM="81bfecf96c53ac7fc61878bd0acb5215"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python-gammu wxPython3"
+REQUIRES="python2-gammu wxPython3"
MAINTAINER="Heinz Wiesinger"
-EMAIL="pprkut@liwjatan.at"
+EMAIL="pprkut@slackbuilds.org"