summaryrefslogtreecommitdiffstats
path: root/office/smoffice2018/smoffice2018.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'office/smoffice2018/smoffice2018.SlackBuild')
-rw-r--r--office/smoffice2018/smoffice2018.SlackBuild26
1 files changed, 21 insertions, 5 deletions
diff --git a/office/smoffice2018/smoffice2018.SlackBuild b/office/smoffice2018/smoffice2018.SlackBuild
index cefea3a791..e30bee3fde 100644
--- a/office/smoffice2018/smoffice2018.SlackBuild
+++ b/office/smoffice2018/smoffice2018.SlackBuild
@@ -1,10 +1,10 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for smoffice2018
# Based on the Arch Linux PKGBUILD.
-# Copyright 2018-2019, Alexander Verbovetsky, Moscow, Russia
+# Copyright 2018-2020, Alexander Verbovetsky, Moscow, Russia
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,10 +24,19 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220217 bkw: Modified by SlackBuilds.org: updated for v2018_982.
+# Note: upstream plays a dirty trick on us. When they release a new
+# version, they don't just remove the old download links... they make
+# the old links redirect to the latest version. Which is why I've
+# hosted v2018_982 on slackware.uk.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=smoffice2018
-VERSION=${VERSION:-2018_972}
+VERSION=${VERSION:-2018_982}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -44,7 +53,14 @@ case "$ARCH" in
exit 1 ;;
esac
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -106,4 +122,4 @@ mkdir -p install
cat $CWD/slack-desc > install/slack-desc
cat $CWD/doinst.sh > install/doinst.sh
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE