summaryrefslogtreecommitdiffstats
path: root/office/python-gcalcli/python-gcalcli.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'office/python-gcalcli/python-gcalcli.SlackBuild')
-rw-r--r--office/python-gcalcli/python-gcalcli.SlackBuild13
1 files changed, 8 insertions, 5 deletions
diff --git a/office/python-gcalcli/python-gcalcli.SlackBuild b/office/python-gcalcli/python-gcalcli.SlackBuild
index 5cc034cf31..9567670235 100644
--- a/office/python-gcalcli/python-gcalcli.SlackBuild
+++ b/office/python-gcalcli/python-gcalcli.SlackBuild
@@ -22,7 +22,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=python-gcalcli
-VERSION=${VERSION:-git20140429}
+VERSION=${VERSION:-4.3.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -61,7 +61,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.xz
+tar xvf $CWD/$SRCNAM-$VERSION.tar.?z
cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
@@ -70,14 +70,17 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+mv $PKG/usr/share/man $PKG/usr
+gzip -9 $PKG/usr/man/man1/gcalcli.1
+rm -rf $PKG/usr/share
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- ChangeLog README.md docs \
+cp -a ChangeLog LICENSE docs/README.md \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild