summaryrefslogtreecommitdiffstats
path: root/office/fbreader/fbreader.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'office/fbreader/fbreader.SlackBuild')
-rw-r--r--office/fbreader/fbreader.SlackBuild34
1 files changed, 24 insertions, 10 deletions
diff --git a/office/fbreader/fbreader.SlackBuild b/office/fbreader/fbreader.SlackBuild
index d5c54adeac..b82dd3ea8c 100644
--- a/office/fbreader/fbreader.SlackBuild
+++ b/office/fbreader/fbreader.SlackBuild
@@ -1,30 +1,40 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for fbreader
# Originally written by Audrius Kazukauskas <audrius@neutrino.lt>
# Maintained as of version 0.12.1 by Niels Horn <niels.horn@gmail.com>
# revision date: 2011/03/09
+# Modified by SlackBuilds.org, 20230111 bkw: BUILD=2, just to force a
+# rebuild after libunibreak update to 5.1.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=fbreader
VERSION=${VERSION:-0.99.4}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
ARCHQUADLET=""
elif [ "$ARCH" = "i686" ]; then
@@ -56,14 +66,18 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Needed for gcc >= 6.x
+sed -i "s|-Wall|-Wall -Wno-narrowing|" makefiles/arch/desktop.mk
patch -p1 < $CWD/fbreader-0.99.4.patch
+# Port to qt5 - patch from gentoo
+patch -p1 < $CWD/fbreader-qt5.patch
export TARGET_ARCH=desktop
-export UI_TYPE=qt4
+export UI_TYPE=qt4 # this hasn't changed
export TARGET_STATUS=release
-make LIBDIR=/usr/lib${LIBDIRSUFFIX} ZLSHARED=no MOC=/usr/bin/moc
-make install LIBDIR=/usr/lib${LIBDIRSUFFIX} ZLSHARED=no DESTDIR=$PKG
+make LIBDIR=/usr/lib${LIBDIRSUFFIX}
+make install LIBDIR=/usr/lib${LIBDIRSUFFIX} DESTDIR=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -80,4 +94,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE