summaryrefslogtreecommitdiffstats
path: root/office/evince/evince.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'office/evince/evince.SlackBuild')
-rw-r--r--office/evince/evince.SlackBuild122
1 files changed, 46 insertions, 76 deletions
diff --git a/office/evince/evince.SlackBuild b/office/evince/evince.SlackBuild
index a1f6e48489..730b0a038a 100644
--- a/office/evince/evince.SlackBuild
+++ b/office/evince/evince.SlackBuild
@@ -1,8 +1,8 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for evince
-# Copyright 2009 Andrew Brouwers <abrouwers@gmail.com>
+# Copyright 2009 Andrew Brouwers <email removed>
# Copyright 2009-2014, Michiel van Wessem, Manchester, United Kingdom.
# Copyright 2019, B. Watson
# All rights reserved.
@@ -24,18 +24,17 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-# Now maintained by B. Watson <yalhcru@gmail.com>
+# Now maintained by B. Watson <urchlay@slackware.uk>
-# 20191231 bkw:
-# - take over maintenance
-# - update for v3.28.5.3, which is the last version that will build with
-# Slack 14.2's rather outdated gtk+3 libraries. Actually it requires
-# some fugly hackery to work, see shim.h for gory details and polemic.
+# 20230104 bkw: update for v41.5 (see README for why it's not 42.x or 43.x)
+
+cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=evince
-VERSION=${VERSION:-3.28.5}
+VERSION=${VERSION:-41.5}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -45,7 +44,11 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -76,73 +79,40 @@ chown -R root:root .
find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
\! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
-# If we have any patches apply them here:
-# http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/app-text/evince/files/
-
-# 20191231 bkw: I'll leave this here, but I have NOT tested it.
-# It was never documented in README, caveat hactor.
-NLS=${NLS:-YES}
-if [ "$NLS" != "YES" ]; then
- # disable NLS - we're going for a small package here.
- rm po/*.po
- sed -i -e 's/USE_NLS=yes/USE_NLS=no/g' \
- -e 's/ENABLE_NLS 1/ENABLE_NLS 0/g' configure
-fi
+mkdir build
+cd build
+ CFLAGS="$SLKCFLAGS" \
+ CXXFLAGS="$SLKCFLAGS" \
+ meson .. \
+ --buildtype=release \
+ --infodir=/usr/info \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ -Dstrip=true \
+ -Ddbus=${DBUS:-true} \
+ -Dcomics=enabled \
+ -Ddjvu=enabled \
+ -Ddvi=enabled \
+ -Dt1lib=enabled \
+ -Dpdf=enabled \
+ -Dps=enabled \
+ -Dtiff=enabled \
+ -Dnautilus=false \
+ -Dgspell=disabled \
+ -Dsystemduserunitdir=no
+ "${NINJA:=ninja}"
+ DESTDIR=$PKG $NINJA install
+cd ..
+rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
+
+gzip -9 $PKG/usr/man/man1/*.1
-# 20200101 bkw: "shim" to let us actually compile with gtk+-3.18 and
-# glib-2.46.2. Supposedly these versions are supported by evince-3.28.5,
-# but upstream uses a couple of functions that are new in gtk+-3.22
-# and glib-2.52. Fortunately it's stuff we can work around with a few
-# #defines.
-SLKCFLAGS="$SLKCFLAGS -include $CWD/shim.h"
-
-# 20200101 bkw: 14.2's mime stuff identifies djvu files as
-# image/vnd.djvu only, but evince wants image/vnd.djvu+multipage.
-sed -i '/^ *DJVU_MIME_TYPES/s|="|&image/vnd.djvu;|' configure
-
-# If we were building 3.30.x, we'd need this:
-# --without-gspell \
-
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --mandir=/usr/man \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --mandir=/usr/man \
- --docdir=/usr/doc/$PRGNAM-$VERSION \
- --enable-dbus \
- --enable-pdf \
- --enable-tiff \
- --enable-djvu \
- --enable-t1lib \
- --enable-comics \
- --enable-dvi \
- --enable-ps \
- --enable-xps \
- --enable-introspection \
- --disable-static \
- --disable-nautilus \
- --disable-maintainer-mode \
- --with-systemduserunitdir=no \
- --build=$ARCH-slackware-linux
-
-# ugh. glib-genmarshal's flags changed gratuitously.
-sed -i 's,--prototypes,--header,' libview/Makefile
-
-make V=1
-make install-strip DESTDIR=$PKG
-
-# Fix desktop entry
-sed -i "/NoDisplay=true/d" $PKG/usr/share/applications/evince.desktop
-
-gzip -9 $PKG/usr/man/man1/$PRGNAM.1
-
-rm -rf $PKG/{usr/share/gtk-doc,etc}
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS COPYING NEWS README MAINTAINERS $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS COPYING NEWS *.md MAINTAINERS NEWS NOTES TODO \
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
@@ -150,4 +120,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE