summaryrefslogtreecommitdiffstats
path: root/office/abook/abook.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'office/abook/abook.SlackBuild')
-rw-r--r--office/abook/abook.SlackBuild18
1 files changed, 14 insertions, 4 deletions
diff --git a/office/abook/abook.SlackBuild b/office/abook/abook.SlackBuild
index 45031e240b..e723fc2b1b 100644
--- a/office/abook/abook.SlackBuild
+++ b/office/abook/abook.SlackBuild
@@ -1,4 +1,4 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for abook
@@ -25,10 +25,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=abook
VERSION=${VERSION:-0.6.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -38,7 +41,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -75,7 +85,7 @@ find -L . \
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
aclocal && automake --add-missing && autoconf
-sed 's/0.18/0.19/g' -i po/Makefile.in.in
+sed 's/0.18/0.20/g' -i po/Makefile.in.in
# thanks to the archers for this patch ;)
patch -p1 -i $CWD/gcc5.patch
@@ -106,4 +116,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE