summaryrefslogtreecommitdiffstats
path: root/network/xombrero/Makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'network/xombrero/Makefile.patch')
-rw-r--r--network/xombrero/Makefile.patch39
1 files changed, 23 insertions, 16 deletions
diff --git a/network/xombrero/Makefile.patch b/network/xombrero/Makefile.patch
index b3c7758f3d..3bf61313d7 100644
--- a/network/xombrero/Makefile.patch
+++ b/network/xombrero/Makefile.patch
@@ -1,29 +1,36 @@
---- Makefile 2012-11-28 11:23:15.000000000 -0700
-+++ Makefile.new 2013-02-08 10:21:31.839628119 -0700
-@@ -61,15 +61,21 @@
- install -m 755 -d $(DESTDIR)$(LIBDIR)
+--- Makefile 2013-07-11 11:05:15.000000000 -0600
++++ Makefile.new 2013-09-04 22:10:27.708971431 -0600
+@@ -25,6 +25,7 @@
+ APPDIR?= $(PREFIX)/share/applications
+ MANDIR?= $(PREFIX)/share/man
+ RESDIR?= $(PREFIX)/share/xombrero
++ICODIR?= $(PREFIX)/share/icons/hicolor/apps
+
+ SRCS= $(shell ls ../*.c)
+ SRCS+= linux.c
+@@ -63,15 +64,20 @@
install -m 755 -d $(DESTDIR)$(MANDIR)/man1
install -m 755 -d $(DESTDIR)$(RESDIR)
-+ install -m 755 -d $(DESTDIR)$(PREFIX)/share/applications
-+ install -m 755 -d $(DESTDIR)$(PREFIX)/share/icons/hicolor/apps/16x16
-+ install -m 755 -d $(DESTDIR)$(PREFIX)/share/icons/hicolor/apps/32x32
-+ install -m 755 -d $(DESTDIR)$(PREFIX)/share/icons/hicolor/apps/48x48
-+ install -m 755 -d $(DESTDIR)$(PREFIX)/share/icons/hicolor/apps/64x64
-+ install -m 755 -d $(DESTDIR)$(PREFIX)/share/icons/hicolor/apps/128x128
+ install -m 755 -d $(DESTDIR)$(APPDIR)
++ install -m 755 -d $(DESTDIR)$(ICODIR)/16x16
++ install -m 755 -d $(DESTDIR)$(ICODIR)/32x32
++ install -m 755 -d $(DESTDIR)$(ICODIR)/48x48
++ install -m 755 -d $(DESTDIR)$(ICODIR)/64x64
++ install -m 755 -d $(DESTDIR)$(ICODIR)/128x128
install -m 755 xombrero $(DESTDIR)$(BINDIR)
install -m 644 ../xombrero.1 $(DESTDIR)$(MANDIR)/man1/xombrero.1
install -m 644 ../xombrero.css $(DESTDIR)$(RESDIR)
- install -m 644 ../xombrero.desktop $(DESTDIR)$(PREFIX)/share/applications
+ install -m 644 ../xombrero.desktop $(DESTDIR)$(APPDIR)
- install -m 644 ../xombreroicon16.png $(DESTDIR)$(RESDIR)
- install -m 644 ../xombreroicon32.png $(DESTDIR)$(RESDIR)
- install -m 644 ../xombreroicon48.png $(DESTDIR)$(RESDIR)
- install -m 644 ../xombreroicon64.png $(DESTDIR)$(RESDIR)
- install -m 644 ../xombreroicon128.png $(DESTDIR)$(RESDIR)
-+ install -m 644 ../xombreroicon16.png $(DESTDIR)$(PREFIX)/share/icons/hicolor/apps/16x16/xombrero.png
-+ install -m 644 ../xombreroicon32.png $(DESTDIR)$(PREFIX)/share/icons/hicolor/apps/32x32/xombrero.png
-+ install -m 644 ../xombreroicon48.png $(DESTDIR)$(PREFIX)/share/icons/hicolor/apps/48x48/xombrero.png
-+ install -m 644 ../xombreroicon64.png $(DESTDIR)$(PREFIX)/share/icons/hicolor/apps/64x64/xombrero.png
-+ install -m 644 ../xombreroicon128.png $(DESTDIR)$(PREFIX)/share/icons/hicolor/apps/128x128/xombrero.png
++ install -m 644 ../xombreroicon16.png $(DESTDIR)$(ICODIR)/16x16
++ install -m 644 ../xombreroicon32.png $(DESTDIR)$(ICODIR)/32x32
++ install -m 644 ../xombreroicon48.png $(DESTDIR)$(ICODIR)/48x48
++ install -m 644 ../xombreroicon64.png $(DESTDIR)$(ICODIR)/64x64
++ install -m 644 ../xombreroicon128.png $(DESTDIR)$(ICODIR)/128x128
install -m 644 ../tld-rules $(DESTDIR)$(RESDIR)
install -m 644 ../style.css $(DESTDIR)$(RESDIR)
install -m 644 ../hsts-preload $(DESTDIR)$(RESDIR)