summaryrefslogtreecommitdiffstats
path: root/network/synergy/synergy.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'network/synergy/synergy.SlackBuild')
-rw-r--r--network/synergy/synergy.SlackBuild74
1 files changed, 47 insertions, 27 deletions
diff --git a/network/synergy/synergy.SlackBuild b/network/synergy/synergy.SlackBuild
index adfcef3e4e..83d53f68fc 100644
--- a/network/synergy/synergy.SlackBuild
+++ b/network/synergy/synergy.SlackBuild
@@ -1,8 +1,9 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for "synergy".
# Copyright 2013-2016 Marcel Saegebarth <marc@mos6581.de>
+# Copyright 2020-2023 Christoph Willing Brisbane, Australia
# All rights reserved.
#
# Redistribution and use in source and binary forms, with or without
@@ -24,26 +25,37 @@
# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=synergy
-VERSION=${VERSION:-1.7.6}
+SRCNAM=synergy-core
+VERSION=${VERSION:-1.14.6.19}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -61,9 +73,10 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION-stable
-tar xvf $CWD/v$VERSION-stable.tar.gz || tar xvf $CWD/$PRGNAM-$VERSION-stable.tar.gz
-cd $PRGNAM-$VERSION-stable
+rm -rf $SRCNAM-$VERSION-stable
+tar xvf $CWD/$SRCNAM-$VERSION-stable.tar.gz
+cd $SRCNAM-$VERSION-stable
+
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -71,40 +84,47 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Thanks Christoph Willing
-patch -p0 < $CWD/010_include_dns_sd.diff
-
-sh hm.sh configure --generator=1 --release
-CXXFLAGS="$SLKCFLAGS" sh hm.sh build
+#Remove the submodule pugixml
+sed -i.remove-sub-pugixml -e '/pugixml/ s/^/#/' src/lib/synergy/CMakeLists.txt
+sed -i.add-lib-pugixml -e '/target_link_libraries(synlib arch/ s/target_link_libraries(synlib arch \(.*\))/target_link_libraries(synlib arch \1 pugixml)/' src/lib/synergy/CMakeLists.txt
+
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DBUILD_TESTS=false \
+ -DSYNERGY_VERSION_STAGE:STRING=stable \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make
+ make install/strip DESTDIR=$PKG
+ install -s -m 0755 bin/synergyd $PKG/usr/bin/
+cd ..
# installation not implemented
mkdir -p $PKG/usr/bin $PKG/usr/doc/$PRGNAM-$VERSION $PKG/usr/man/man1 \
$PKG/usr/share/icons/hicolor/256x256 $PKG/usr/share/applications
-for file in synergy synergyc synergyd synergys syntool usynergy ; do
- install -s -m 0755 $TMP/$PRGNAM-$VERSION-stable/bin/$file $PKG/usr/bin
-done
-
for file in synergy.conf.example synergy.conf.example-advanced synergy.conf.example-basic ; do
- install -m 0644 $TMP/$PRGNAM-$VERSION-stable/doc/$file $PKG/usr/doc/$PRGNAM-$VERSION
-done
-
-for file in COMPILE ChangeLog INSTALL LICENSE README ; do
- install -m 0644 $TMP/$PRGNAM-$VERSION-stable/$file $PKG/usr/doc/$PRGNAM-$VERSION
+ install -m 0644 $TMP/$SRCNAM-$VERSION-stable/doc/$file $PKG/usr/doc/$PRGNAM-$VERSION
done
for file in synergyc.man synergys.man ; do
- install -m 0644 $TMP/$PRGNAM-$VERSION-stable/doc/$file $PKG/usr/man/man1
+ install -m 0644 $TMP/$SRCNAM-$VERSION-stable/doc/$file $PKG/usr/man/man1
done
find $PKG/usr/man/man1 -type f -name "*.man" -exec rename '.man' '.1' {} \;
find $PKG/usr/man/man1 -type f -name "*.?" -exec gzip -9f {} \;
-install -m 0644 $TMP/$PRGNAM-$VERSION-stable/res/synergy.ico \
+install -m 0644 $TMP/$SRCNAM-$VERSION-stable/res/synergy.ico \
$PKG/usr/share/icons/hicolor/256x256
-install -D -m 0644 $TMP/$PRGNAM-$VERSION-stable/res/synergy.desktop \
+install -D -m 0644 $TMP/$SRCNAM-$VERSION-stable/res/synergy.desktop \
$PKG/usr/share/applications
+for file in ChangeLog LICENSE README.md ; do
+ install -m 0644 $TMP/$SRCNAM-$VERSION-stable/$file $PKG/usr/doc/$PRGNAM-$VERSION
+done
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
@@ -112,4 +132,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE