summaryrefslogtreecommitdiffstats
path: root/network/sic/sic.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'network/sic/sic.SlackBuild')
-rw-r--r--network/sic/sic.SlackBuild99
1 files changed, 77 insertions, 22 deletions
diff --git a/network/sic/sic.SlackBuild b/network/sic/sic.SlackBuild
index 33638e6832..cc4b1bf885 100644
--- a/network/sic/sic.SlackBuild
+++ b/network/sic/sic.SlackBuild
@@ -1,7 +1,8 @@
-#!/bin/sh
+#!/bin/bash
#
# Slackware build script for sic
-# Copyright 2011 Haroldo F. Jardim <hfjardim@gmail.com>
+# Copyright 2011 Haroldo F. Jardim <email removed>
+# Now maintained by B. Watson <urchlay@slackware.uk>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -21,26 +22,52 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20230103 bkw: update for v1.3, strip binary.
+
+# 20210924 bkw:
+# - update for latest git.
+# - add support for SLASH=yes.
+# - add support for user config.h.
+# - add support for patches.
+# - update README to reflect the above.
+
+# 20201113 bkw: The original author of this script hasn't been heard
+# from since 2011, and it needs some attention (still mentions i486)
+# so I'm taking it.
+# - new maintainer
+# - i486 => i586
+# - fix that => than typo in slack-desc
+# - expand README a bit
+# - add env vars for default host and port
+# - simplify script
+
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=sic
-VERSION=${VERSION:-1.1}
+VERSION=${VERSION:-1.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -59,37 +86,65 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvzf $CWD/$PRGNAM-$VERSION.tar.gz
+tar xvf $CWD/$PRGNAM-$VERSION.tar.[xg]z
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+chmod 644 *
+
+# this is more complex than it has to be: upstream released a a mix
+# of -p0 and -p1 patches.
+for i in $CWD/patches/*.diff; do
+ if [ -e "$i" ]; then
+ P=1
+ patch --dry-run -p0 < $i &>/dev/null && P=0
+ echo "=== Applying $( basename $i ) with -p$P"
+ patch -p$P < $i
+ fi
+done
+
+if [ -e "$CWD/config.h" ]; then
+ # if the user's got his own config.h, use it
+ cat "$CWD/config.h" > config.h
+else
+ # if not, use the upstream default
+ cat config.def.h > config.h
+fi
+
+# IRCHOST IRCPORT SLASH modify the config.h, even overriding what's
+# in the user's custom one. Also fixup the man page.
+if [ -n "$IRCHOST" ]; then
+ sed -i "/DEFAULT_HOST/s,\".*\"\$,\"$IRCHOST\"," config.h
+ sed -i "/default host/s,(.*) *$,($IRCHOST)," $PRGNAM.1
+fi
-sed -i "s/CFLAGS =/CFLAGS +=/" config.mk
+if [ -n "$IRCPORT" ]; then
+ sed -i "/DEFAULT_PORT/s,\".*\"\$,\"$IRCPORT\"," config.h
+ sed -i "/default port/s,(.*) *$,($IRCPORT)," $PRGNAM.1
+fi
+
+if [ "${SLASH:-no}" = "yes" ]; then
+ sed -i "s|':'|'/'|" config.h
+ sed -i '/^\.BI :/s,:,/,' $PRGNAM.1
+fi
CFLAGS="$SLKCFLAGS" \
DESTDIR=$PKG \
make \
+ VERSION="$VERSION" \
+ CFLAGS="$SLKCFLAGS" \
PREFIX=/usr \
MANPREFIX=/usr/man \
install
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+strip $PKG/usr/bin/$PRGNAM
+gzip -9 $PKG/usr/man/man1/$PRGNAM.1
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE README $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README config.h $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-find $PKG/usr/doc -type f -exec chmod 0644 {} \;
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE