summaryrefslogtreecommitdiffstats
path: root/network/remmina/remmina.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'network/remmina/remmina.SlackBuild')
-rw-r--r--network/remmina/remmina.SlackBuild15
1 files changed, 7 insertions, 8 deletions
diff --git a/network/remmina/remmina.SlackBuild b/network/remmina/remmina.SlackBuild
index bc516e4c4b..27628ae3c8 100644
--- a/network/remmina/remmina.SlackBuild
+++ b/network/remmina/remmina.SlackBuild
@@ -7,7 +7,7 @@
PRGNAM=remmina
VERSION=${VERSION:-1.0.0}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
SRCNAM=Remmina
@@ -63,6 +63,11 @@ sed "s|/lib/remmina|/lib$LIBDIRSUFFIX/remmina|g" -i CMakeLists.txt
# gcc-4.7.x needs additional linker flags
SLKLDFLAGS="-lX11 -lgio-2.0 -lgobject-2.0 -lgthread-2.0 -lgmodule-2.0 -lgdk_pixbuf-2.0 -lpthread"
+# Apply a whole lotta patches...
+for i in $CWD/patches/*; do
+ patch -p1 -i $i
+done
+
# VTE support must explicitly be disabled because it's detected in
# but the version is not high enough (>=2.90).
# The same for appindicator.
@@ -79,19 +84,13 @@ cd build
-DWITH_APPINDICATOR=OFF \
-DCMAKE_BUILD_TYPE=Release ..
- make VERBOSE=1
+ make VERBOSE=1
make install DESTDIR=$PKG
cd ..
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-# Install desktop file (went MIA upstream, but they already fixed it in
-# their git repo it seems - so check with next update...)
-mkdir -p $PKG/usr/share/{applications,pixmaps}
-cat $CWD/$PRGNAM.desktop > $PKG/usr/share/applications/$PRGNAM.desktop
-cat remmina/desktop/scalable/apps/$PRGNAM.svg > $PKG/usr/share/pixmaps/$PRGNAM.svg
-
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/{remmina,remmina-plugins}
cp -a README $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \