summaryrefslogtreecommitdiffstats
path: root/network/qutebrowser/qutebrowser.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'network/qutebrowser/qutebrowser.SlackBuild')
-rw-r--r--network/qutebrowser/qutebrowser.SlackBuild72
1 files changed, 24 insertions, 48 deletions
diff --git a/network/qutebrowser/qutebrowser.SlackBuild b/network/qutebrowser/qutebrowser.SlackBuild
index 33d381dbe4..66a1688230 100644
--- a/network/qutebrowser/qutebrowser.SlackBuild
+++ b/network/qutebrowser/qutebrowser.SlackBuild
@@ -1,30 +1,16 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for qutebrowser
-# Copyright 2017 Dave Woodfall <dave@slackbuilds.org>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# written by Dave Woodfall <dave@slackbuilds.org>
+# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/
+
+cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=qutebrowser
-VERSION=${VERSION:-1.10.1}
-BUILD=${BUILD:-1}
+VERSION=${VERSION:-2.5.4}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -34,25 +20,18 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -68,20 +47,17 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-make -f misc/Makefile install DESTDIR=$PKG PREFIX=/usr
-
-find $PKG -name \*\.opt-1.pyc -exec rm -f {} \;
+make -f misc/Makefile install DESTDIR=$PKG PREFIX=/usr MANDIR=/usr/man
-mkdir -p $PKG/usr/share/pixmaps
-cp icons/qutebrowser.xpm $PKG/usr/share/pixmaps/
+# shouldn't be executable
+chmod -x $PKG/usr/share/$PRGNAM/userscripts/README.md
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+find $PKG -name \*\.opt-1.pyc -exec rm -f {} \;
-mv $PKG/usr/share/man $PKG/usr
+install -D -m 0644 icons/qutebrowser.xpm \
+ $PKG/usr/share/pixmaps/qutebrowser.xpm
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+gzip -9 $PKG/usr/man/man1/qutebrowser.1
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a LICENSE README.asciidoc $PKG/usr/doc/$PRGNAM-$VERSION
@@ -92,4 +68,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE