summaryrefslogtreecommitdiffstats
path: root/network/privoxy/privoxy.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'network/privoxy/privoxy.SlackBuild')
-rw-r--r--network/privoxy/privoxy.SlackBuild32
1 files changed, 18 insertions, 14 deletions
diff --git a/network/privoxy/privoxy.SlackBuild b/network/privoxy/privoxy.SlackBuild
index bc9c730052..8ebfd726b4 100644
--- a/network/privoxy/privoxy.SlackBuild
+++ b/network/privoxy/privoxy.SlackBuild
@@ -1,9 +1,9 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for privoxy
# Copyright (c) 2007 alkos333 <me@alkos333.net>
-# Copyright 2014-2021 Kyle Guinn <elyk03@gmail.com>
+# Copyright 2014-2023 Kyle Guinn <elyk03@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,10 +23,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=privoxy
-VERSION=${VERSION:-3.0.29}
+VERSION=${VERSION:-3.0.34}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$(uname -m)" in
@@ -36,15 +39,16 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM-$VERSION
+PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i586" ]; then
+if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
@@ -89,14 +93,13 @@ chmod -R u+w,go-w,a+rX-st .
# Put the docs where we tell them to go.
sed -i "/^DOC_DEST/s/= .*/= @docdir@/" GNUmakefile.in
-# The Makefile checks if certain config files exist, and if so, adds a
-# .new suffix. Turn this behavior off. We will do it below.
-sed -i "s/\[ -s \"\$(CONF_DEST)\/\$\$i\" \]/false/" GNUmakefile.in
-
# rc.privoxy generation doesn't work well with $(DESTDIR). Help it along.
sed -i "s/ \/etc\/rc.d\// \$(DESTDIR)\/etc\/rc.d\//g" GNUmakefile.in
mkdir -p $PKG/etc/rc.d
+# Let AC_CHECK_LIB do the brotli autodetection, don't link to it if missing.
+sed -i "/-lbrotlidec/d" configure.in
+
autoreconf -vif
./configure \
--prefix=/usr \
@@ -111,6 +114,7 @@ autoreconf -vif
--with-user=$PRIVOXY_USER \
--with-group=$PRIVOXY_GROUP \
--with-openssl \
+ --with-brotli \
--enable-no-gifs \
--enable-compression \
--enable-large-file-support \
@@ -146,4 +150,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE